Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
154f6156
Commit
154f6156
authored
9 years ago
by
David Thompson
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add allegro-4.
* gnu/packages/game-development.scm (allegro-4): New variable.
parent
921d9dc7
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/game-development.scm
+39
-0
39 additions, 0 deletions
gnu/packages/game-development.scm
with
39 additions
and
0 deletions
gnu/packages/game-development.scm
+
39
−
0
View file @
154f6156
...
...
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Julian Graham <joolean@gmail.com>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -295,3 +296,41 @@ (define-public love
programming language."
)
(
home-page
"https://love2d.org/"
)
(
license
license:zlib
)))
(
define-public
allegro-4
(
package
(
name
"allegro"
)
(
version
"4.4.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://download.gna.org/allegro/allegro/"
version
"/allegro-"
version
".tar.gz"
))
(
sha256
(
base32
"1p0ghkmpc4kwij1z9rzxfv7adnpy4ayi0ifahlns1bdzgmbyf88v"
))))
(
build-system
cmake-build-system
)
(
arguments
'
(
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'patch-build-system
(
lambda
_
;; Build addons as shared libraries. Trying to set ADDON_LINKAGE
;; via a command line option doesn't work because it is
;; unconditionally clobbered in the build script.
(
substitute*
'
(
"CMakeLists.txt"
)
((
"ADDON_LINKAGE STATIC"
)
"ADDON_LINKAGE SHARED"
))
#t
)))))
(
inputs
`
((
"glu"
,
glu
)
(
"libpng"
,
libpng
)
(
"libvorbis"
,
libvorbis
)
(
"mesa"
,
mesa
)
(
"zlib"
,
zlib
)))
(
synopsis
"Game programming library"
)
(
description
"Allegro is a library mainly aimed at video game and
multimedia programming. It handles common, low-level tasks such as creating
windows, accepting user input, loading data, drawing images, playing sounds,
etc."
)
(
home-page
"http://liballeg.org"
)
(
license
license:giftware
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment