Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
15606d98
Unverified
Commit
15606d98
authored
6 years ago
by
Christopher Baines
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add ruby-sprockets.
* gnu/packages/ruby.scm (ruby-sprockets): New variable.
parent
c8f079ca
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ruby.scm
+25
-0
25 additions, 0 deletions
gnu/packages/ruby.scm
with
25 additions
and
0 deletions
gnu/packages/ruby.scm
+
25
−
0
View file @
15606d98
...
...
@@ -7557,3 +7557,28 @@ (define-public ruby-globalid
uniquely identify it."
)
(
home-page
"https://rubyonrails.org/"
)
(
license
license:expat
)))
(
define-public
ruby-sprockets
(
package
(
name
"ruby-sprockets"
)
(
version
"3.7.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
rubygems-uri
"sprockets"
version
))
(
sha256
(
base32
"182jw5a0fbqah5w9jancvfmjbk88h8bxdbwnl4d3q809rpxdg8ay"
))))
(
build-system
ruby-build-system
)
(
arguments
'
(
;; No included tests
#
:tests?
#f
))
(
propagated-inputs
`
((
"ruby-concurrent"
,
ruby-concurrent
)
(
"ruby-rack"
,
ruby-rack
)))
(
synopsis
"Sprockets is a Rack-based asset packaging system"
)
(
description
"Sprockets is a Rack-based asset packaging system that concatenates and
serves JavaScript, CoffeeScript, CSS, LESS, Sass, and SCSS."
)
(
home-page
"https://github.com/rails/sprockets"
)
(
license
license:expat
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment