Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
1581406e
Unverified
Commit
1581406e
authored
8 years ago
by
Marius Bakke
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add efibootmgr.
* gnu/packages/linux.scm (efibootmgr): New variable.
parent
0d74462a
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/linux.scm
+45
-0
45 additions, 0 deletions
gnu/packages/linux.scm
with
45 additions
and
0 deletions
gnu/packages/linux.scm
+
45
−
0
View file @
1581406e
...
...
@@ -3152,3 +3152,48 @@ (define-public efivar
(
description
"This package provides a library and a command line
interface to the variable facility of UEFI boot firmware."
)
(
license
license:lgpl2
.
1
+
)))
(
define-public
efibootmgr
(
package
(
name
"efibootmgr"
)
(
version
"14"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/rhinstaller/"
name
"/releases/download/"
version
"/"
name
"-"
version
".tar.bz2"
))
(
sha256
(
base32
"1n3sydvpr6yl040hhf460k7mrxby7laqd9dqs6pq0js1hijc2zip"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:tests?
#f
; No tests.
#
:make-flags
(
list
(
string-append
"prefix="
%output
)
(
string-append
"libdir="
%output
"/lib"
)
;; Override CFLAGS to add efivar include directory.
(
string-append
"CFLAGS=-O2 -g -flto -I"
(
assoc-ref
%build-inputs
"efivar"
)
"/include/efivar"
))
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'branding
;; Replace default loader path with something more familiar.
(
lambda
_
(
substitute*
"src/efibootmgr.c"
((
"EFI\\\\\\\\redhat"
)
; Matches 'EFI\\redhat'.
"EFI\\\\gnu"
))
#t
))
(
delete
'configure
))))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"efivar"
,
efivar
)
(
"popt"
,
popt
)))
(
home-page
"https://github.com/rhinstaller/efibootmgr"
)
(
synopsis
"Modify the Extensible Firmware Interface (EFI) boot manager"
)
(
description
"@code{efibootmgr} is a user-space application to modify the Intel
Extensible Firmware Interface (EFI) Boot Manager. This application can
create and destroy boot entries, change the boot order, change the next
running boot option, and more."
)
(
license
license:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment