Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
159daace
Unverified
Commit
159daace
authored
8 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add mcron2.
* gnu/packages/guile.scm (mcron2): New variable.
parent
c5eef242
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/guile.scm
+50
-0
50 additions, 0 deletions
gnu/packages/guile.scm
with
50 additions
and
0 deletions
gnu/packages/guile.scm
+
50
−
0
View file @
159daace
...
...
@@ -42,6 +42,7 @@ (define-module (gnu packages guile)
#
:use-module
(
gnu
packages
ed
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
texinfo
)
#
:use-module
(
gnu
packages
man
)
#
:use-module
(
gnu
packages
gettext
)
#
:use-module
(
gnu
packages
databases
)
#
:use-module
(
gnu
packages
python
)
...
...
@@ -421,6 +422,55 @@ (define-public mcron
format is also supported."
)
(
license
gpl3+
)))
(
define-public
mcron2
;; This is mthl's mcron development branch, not yet merged in mcron.
(
let
((
commit
"31baff1a5187d8ddc89324cbe42dbeffc309c962"
))
(
package
(
inherit
mcron
)
(
name
"mcron2"
)
(
version
(
string-append
(
package-version
mcron
)
"-0."
(
string-take
commit
7
)))
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
"https://notabug.org/mthl/mcron/"
)
(
commit
commit
)))
(
sha256
(
base32
"1h5wxy997hxi718hpx419c23q09939kbxrjbbq54lv0cgw1bb63z"
))
(
file-name
(
string-append
name
"-"
version
"-checkout"
))))
(
native-inputs
`
((
"autoconf"
,
autoconf
)
(
"automake"
,
automake
)
(
"pkg-config"
,
pkg-config
)
(
"texinfo"
,
texinfo
)
(
"help2man"
,
help2man
)))
(
arguments
`
(
#
:modules
((
ice-9
match
)
(
ice-9
ftw
)
,@
%gnu-build-system-modules
)
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'bootstrap
(
lambda
_
(
zero?
(
system*
"autoreconf"
"-vfi"
))))
(
add-after
'install
'wrap-mcron
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
;; Wrap the 'mcron' command to refer to the right
;; modules.
(
let*
((
out
(
assoc-ref
outputs
"out"
))
(
bin
(
string-append
out
"/bin"
))
(
site
(
string-append
out
"/share/guile/site"
)))
(
match
(
scandir
site
)
((
"."
".."
version
)
(
let
((
modules
(
string-append
site
"/"
version
)))
(
wrap-program
(
string-append
bin
"/mcron"
)
`
(
"GUILE_LOAD_PATH"
":"
prefix
(
,modules
))
`
(
"GUILE_LOAD_COMPILED_PATH"
":"
prefix
(
,modules
)))
#t
))))))))))))
(
define-public
guile-lib
(
package
(
name
"guile-lib"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment