Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
17b293a0
Commit
17b293a0
authored
11 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add alsa-utils.
* gnu/packages/linux.scm (alsa-utils): New variable.
parent
ae0c1202
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/linux.scm
+44
-0
44 additions, 0 deletions
gnu/packages/linux.scm
with
44 additions
and
0 deletions
gnu/packages/linux.scm
+
44
−
0
View file @
17b293a0
...
@@ -32,7 +32,9 @@ (define-module (gnu packages linux)
...
@@ -32,7 +32,9 @@ (define-module (gnu packages linux)
#
:use-module
(
gnu
packages
algebra
)
#
:use-module
(
gnu
packages
algebra
)
#
:use-module
((
gnu
packages
gettext
)
#
:use-module
((
gnu
packages
gettext
)
#
:renamer
(
symbol-prefix-proc
'g:
))
#
:renamer
(
symbol-prefix-proc
'g:
))
#
:use-module
(
gnu
packages
pulseaudio
)
#
:use-module
(
gnu
packages
attr
)
#
:use-module
(
gnu
packages
attr
)
#
:use-module
(
gnu
packages
xml
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
gnu
))
#
:use-module
(
guix
build-system
gnu
))
...
@@ -477,6 +479,48 @@ (define-public alsa-lib
...
@@ -477,6 +479,48 @@ (define-public alsa-lib
MIDI functionality to the Linux-based operating system."
)
MIDI functionality to the Linux-based operating system."
)
(
license
lgpl2
.
1
+
)))
(
license
lgpl2
.
1
+
)))
(
define-public
alsa-utils
(
package
(
name
"alsa-utils"
)
(
version
"1.0.27.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"ftp://ftp.alsa-project.org/pub/utils/alsa-utils-"
version
".tar.bz2"
))
(
sha256
(
base32
"1sjjngnq50jv5ilwsb4zys6smifni3bd6fn28gbnhfrg14wsrgq2"
))))
(
build-system
gnu-build-system
)
(
arguments
;; XXX: Disable man page creation until we have DocBook.
'
(
#
:configure-flags
(
list
"--disable-xmlto"
(
string-append
"--with-udev-rules-dir="
(
assoc-ref
%outputs
"out"
)
"/lib/udev/rules.d"
))
#
:phases
(
alist-cons-before
'install
'pre-install
(
lambda
_
;; Don't try to mkdir /var/lib/alsa.
(
substitute*
"Makefile"
((
"\\$\\(MKDIR_P\\) .*ASOUND_STATE_DIR.*"
)
"true\n"
)))
%standard-phases
)))
(
inputs
`
((
"libsamplerate"
,
libsamplerate
)
(
"ncurses"
,
ncurses
)
(
"alsa-lib"
,
alsa-lib
)
(
"xmlto"
,
xmlto
)
(
"gettext"
,
g:gettext
)))
(
home-page
"http://www.alsa-project.org/"
)
(
synopsis
"Utilities for the Advanced Linux Sound Architecture (ALSA)"
)
(
description
"The Advanced Linux Sound Architecture (ALSA) provides audio and
MIDI functionality to the Linux-based operating system."
)
;; This is mostly GPLv2+ but a few files such as 'alsactl.c' are
;; GPLv2-only.
(
license
gpl2
)))
(
define-public
iptables
(
define-public
iptables
(
package
(
package
(
name
"iptables"
)
(
name
"iptables"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment