Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
18d26210
Commit
18d26210
authored
10 years ago
by
Mark H Weaver
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add emacs-w3m.
* gnu/packages/emacs.scm (emacs-w3m): New variable.
parent
fe4163f3
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/emacs.scm
+77
-0
77 additions, 0 deletions
gnu/packages/emacs.scm
with
77 additions
and
0 deletions
gnu/packages/emacs.scm
+
77
−
0
View file @
18d26210
...
@@ -37,6 +37,9 @@ (define-module (gnu packages emacs)
...
@@ -37,6 +37,9 @@ (define-module (gnu packages emacs)
#
:use-module
(
gnu
packages
giflib
)
#
:use-module
(
gnu
packages
giflib
)
#
:use-module
(
gnu
packages
linux
)
#
:use-module
(
gnu
packages
linux
)
#
:use-module
(
gnu
packages
version-control
)
#
:use-module
(
gnu
packages
version-control
)
#
:use-module
(
gnu
packages
imagemagick
)
#
:use-module
(
gnu
packages
w3m
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
((
gnu
packages
compression
)
#
:use-module
((
gnu
packages
compression
)
#
:renamer
(
symbol-prefix-proc
'compression:
))
#
:renamer
(
symbol-prefix-proc
'compression:
))
#
:use-module
(
gnu
packages
xml
)
#
:use-module
(
gnu
packages
xml
)
...
@@ -249,3 +252,77 @@ (define-public magit
...
@@ -249,3 +252,77 @@ (define-public magit
cherry picking, reverting, merging, rebasing, and other common Git
cherry picking, reverting, merging, rebasing, and other common Git
operations."
)
operations."
)
(
license
gpl3+
)))
(
license
gpl3+
)))
;;;
;;; Web browsing.
;;;
(
define-public
emacs-w3m
(
package
(
name
"emacs-w3m"
)
(
version
"1.4.483+0.20120614"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://debian/pool/main/w/w3m-el/w3m-el_"
version
".orig.tar.gz"
))
(
sha256
(
base32
"0ms181gjavnfk79hhv5xl9llik4c6kj0w3c04kgyif8lcy2sxljx"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"autoconf"
,
autoconf
)))
(
inputs
`
((
"w3m"
,
w3m
)
(
"imagemagick"
,
imagemagick
)
(
"emacs"
,
emacs
)))
(
arguments
'
(
#
:modules
((
guix
build
gnu-build-system
)
(
guix
build
utils
)
(
guix
build
emacs-utils
))
#
:imported-modules
((
guix
build
gnu-build-system
)
(
guix
build
utils
)
(
guix
build
emacs-utils
))
#
:configure-flags
(
let
((
out
(
assoc-ref
%outputs
"out"
)))
(
list
(
string-append
"--with-lispdir="
out
"/share/emacs/site-lisp"
)
(
string-append
"--with-icondir="
out
"/share/images/emacs-w3m"
)))
#
:tests?
#f
; no check target
#
:phases
(
alist-cons-before
'configure
'pre-configure
(
lambda
_
(
zero?
(
system*
"autoconf"
)))
(
alist-cons-before
'build
'patch-exec-paths
(
lambda*
(
#
:key
inputs
outputs
#
:allow-other-keys
)
(
let
((
out
(
assoc-ref
outputs
"out"
))
(
w3m
(
assoc-ref
inputs
"w3m"
))
(
imagemagick
(
assoc-ref
inputs
"imagemagick"
))
(
coreutils
(
assoc-ref
inputs
"coreutils"
)))
(
emacs-substitute-variables
"w3m.el"
(
"w3m-command"
(
string-append
w3m
"/bin/w3m"
))
(
"w3m-touch-command"
(
string-append
coreutils
"/bin/touch"
))
(
"w3m-image-viewer"
(
string-append
imagemagick
"/bin/display"
))
(
"w3m-icon-directory"
(
string-append
out
"/share/images/emacs-w3m"
)))
(
emacs-substitute-variables
"w3m-image.el"
(
"w3m-imagick-convert-program"
(
string-append
imagemagick
"/bin/convert"
))
(
"w3m-imagick-identify-program"
(
string-append
imagemagick
"/bin/identify"
)))
#t
))
(
alist-replace
'install
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
and
(
zero?
(
system*
"make"
"install"
"install-icons"
))
(
with-directory-excursion
(
string-append
(
assoc-ref
outputs
"out"
)
"/share/emacs/site-lisp"
)
(
for-each
delete-file
'
(
"ChangeLog"
"ChangeLog.1"
))
#t
)))
%standard-phases
)))))
(
home-page
"http://emacs-w3m.namazu.org/"
)
(
synopsis
"Simple Web browser for Emacs based on w3m"
)
(
description
"emacs-w3m is an emacs interface for the w3m web browser."
)
(
license
gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment