Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
201cfb81
Commit
201cfb81
authored
9 years ago
by
Sou Bunnbu (宋文武)
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add gst-python.
* gnu/packages/gstreamer.scm (python-gst, python2-gst): New variables.
parent
fa7cf82e
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/gstreamer.scm
+53
-1
53 additions, 1 deletion
gnu/packages/gstreamer.scm
with
53 additions
and
1 deletion
gnu/packages/gstreamer.scm
+
53
−
1
View file @
201cfb81
...
...
@@ -20,10 +20,11 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(
define-module
(
gnu
packages
gstreamer
)
#
:use-module
((
guix
licenses
)
#
:select
(
lgpl2
.
0
+
bsd-2
bsd-3
gpl2+
))
#
:use-module
((
guix
licenses
)
#
:select
(
lgpl2
.
0
+
lgpl2
.
1
+
bsd-2
bsd-3
gpl2+
))
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
utils
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
audio
)
#
:use-module
(
gnu
packages
bison
)
...
...
@@ -400,3 +401,54 @@ (define-public gst-libav
"This GStreamer plugin supports a large number of audio and video
compression formats through the use of the libav library."
)
(
license
gpl2+
)))
(
define-public
python-gst
(
package
(
name
"python-gst"
)
(
version
"1.6.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://gstreamer.freedesktop.org/src/gst-python/"
"gst-python-"
version
".tar.xz"
))
(
sha256
(
base32
"09ci5zvr7lms7mvgbjgsjwaxcl4nq45n1g9pdwnqmx3rf0qkwxjf"
))))
(
build-system
gnu-build-system
)
(
arguments
;; XXX: Factorize python-sitedir with python-build-system.
`
(
#
:imported-modules
(
,@%gnu-build-system-modules
(
guix
build
python-build-system
))
#
:configure-flags
(
let*
((
python
(
assoc-ref
%build-inputs
"python"
))
(
python-version
((
@@
(
guix
build
python-build-system
)
get-python-version
)
python
))
(
python-sitedir
(
string-append
"lib/python"
python-version
"/site-packages"
)))
(
list
(
string-append
"--with-pygi-overrides-dir="
%output
"/"
python-sitedir
"/gi/overrides"
)))))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"python"
,
python
)))
(
propagated-inputs
`
((
"gst-plugins-base"
,
gst-plugins-base
)
(
"python-pygobject"
,
python-pygobject
)))
(
home-page
"http://gstreamer.freedesktop.org/"
)
(
synopsis
"GStreamer GObject Introspection overrides for Python"
)
(
description
"This package contains GObject Introspection overrides for Python that can
be used by Python applications using GStreamer."
)
(
license
lgpl2
.
1
+
)
(
properties
`
((
python2-variant
.
,
(
delay
python2-gst
))))))
(
define-public
python2-gst
(
package
(
inherit
python-gst
)
(
name
"python2-gst"
)
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"python"
,
python-2
)))
(
propagated-inputs
`
((
"gst-plugins-base"
,
gst-plugins-base
)
(
"python-pygobject"
,
python2-pygobject
)))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment