Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
20b51b17
Unverified
Commit
20b51b17
authored
6 years ago
by
Arun Isaac
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add pass-rotate.
* gnu/packages/password-utils.scm (pass-rotate): New variable.
parent
34e00c7b
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/password-utils.scm
+29
-0
29 additions, 0 deletions
gnu/packages/password-utils.scm
with
29 additions
and
0 deletions
gnu/packages/password-utils.scm
+
29
−
0
View file @
20b51b17
...
...
@@ -18,6 +18,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -62,6 +63,7 @@ (define-module (gnu packages password-utils)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
python
)
#
:use-module
(
gnu
packages
python-web
)
#
:use-module
(
gnu
packages
suckless
)
#
:use-module
(
gnu
packages
tls
)
#
:use-module
(
gnu
packages
qt
)
...
...
@@ -659,3 +661,30 @@ (define-public fpm2
to use a different password manager."
)
(
home-page
"https://als.regnet.cz/fpm2/"
)
(
license
license:gpl2+
)))
(
define-public
pass-rotate
(
package
(
name
"pass-rotate"
)
(
version
"0.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/SirCmpwn/pass-rotate/archive/"
version
".tar.gz"
))
(
sha256
(
base32
"1svm5nj8bczv2dg8lh2zqqhbsrljqsw9680r03qwgl9vlci90210"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))))
(
build-system
python-build-system
)
(
inputs
`
((
"python-beautifulsoup4"
,
python-beautifulsoup4
)
(
"python-docopt"
,
python-docopt
)
(
"python-html5lib"
,
python-html5lib
)
(
"python-requests"
,
python-requests
)))
(
home-page
"https://github.com/SirCmpwn/pass-rotate"
)
(
synopsis
"Rotate password on online services"
)
(
description
"pass-rotate is a command line utility and python library for
rotating passwords on various web services. It makes it easier to rotate your
passwords, one at a time or in bulk, when security events or routine upkeep of
your online accounts makes it necessary."
)
(
license
license:expat
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment