Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
2152e3c5
Commit
2152e3c5
authored
12 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
build: Add release.nix.
* release.nix: New file. * Makefile.am (EXTRA_DIST): Add it.
parent
202851dd
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
Makefile.am
+1
-1
1 addition, 1 deletion
Makefile.am
release.nix
+55
-0
55 additions, 0 deletions
release.nix
with
56 additions
and
1 deletion
Makefile.am
+
1
−
1
View file @
2152e3c5
...
...
@@ -59,7 +59,7 @@ TESTS_ENVIRONMENT = \
LOG_COMPILER
=
\
$(
GUILE
)
--no-auto-compile
-L
"
$(
top_srcdir
)
"
EXTRA_DIST
=
build-aux/config.rpath
$(
TESTS
)
EXTRA_DIST
=
build-aux/config.rpath
release.nix
$(
TESTS
)
CLEANFILES
=
$(
GOBJECTS
)
*
.log
...
...
This diff is collapsed.
Click to expand it.
release.nix
0 → 100644
+
55
−
0
View file @
2152e3c5
/* Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
This file is part of Guix.
Guix is free software; you can redistribute it and/or modify it
under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 3 of the License, or (at
your option) any later version.
Guix is distributed in the hope that it will be useful, but
WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with Guix. If not, see <http://www.gnu.org/licenses/>. */
/* Release file to build Guix with Nix. Useful to bootstrap Guix on
Guix-enabled Hydra instances. */
let
nixpkgs
=
<
nixpkgs
>
;
jobs
=
{
tarball
=
let
pkgs
=
import
nixpkgs
{};
in
pkgs
.
releaseTools
.
sourceTarball
{
name
=
"guix-tarball"
;
src
=
<
guix
>
;
buildInputs
=
with
pkgs
;
[
guile
];
buildNativeInputs
=
with
pkgs
;
[
gettext
cvs
pkgconfig
];
configureFlags
=
[
"--with-nixpkgs=
${
nixpkgs
}
"
"--with-nix-prefix=
${
pkgs
.
nix
}
"
];
};
build
=
{
system
?
builtins
.
currentSystem
}:
let
pkgs
=
import
nixpkgs
{
inherit
system
;
};
in
pkgs
.
releaseTools
.
nixBuild
{
name
=
"guix"
;
buildInputs
=
[
pkgs
.
guile
];
buildNativeInputs
=
[
pkgs
.
pkgconfig
];
src
=
jobs
.
tarball
;
configureFlags
=
[
"--with-nixpkgs=
${
nixpkgs
}
"
"--with-nix-prefix=
${
pkgs
.
nix
}
"
];
# XXX: The test suite cannot be run currently in the chroot, because
# it expects to have a running nix-worker to talk to.
doCheck
=
false
;
};
};
in
jobs
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment