Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
248c0645
Commit
248c0645
authored
11 years ago
by
Andreas Enge
Browse files
Options
Downloads
Patches
Plain Diff
gnu: libextractor: Add optional inputs.
* gnu/packages/gnunet.scm (libextractor): Add inputs ffmpeg and gstreamer.
parent
5cf3bcd4
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/gnunet.scm
+5
-1
5 additions, 1 deletion
gnu/packages/gnunet.scm
with
5 additions
and
1 deletion
gnu/packages/gnunet.scm
+
5
−
1
View file @
248c0645
...
...
@@ -25,11 +25,13 @@ (define-module (gnu packages gnunet)
#
:use-module
(
gnu
packages
glib
)
#
:use-module
(
gnu
packages
gnupg
)
#
:use-module
(
gnu
packages
gnutls
)
#
:use-module
(
gnu
packages
gstreamer
)
#
:use-module
(
gnu
packages
libjpeg
)
#
:use-module
(
gnu
packages
libtiff
)
#
:use-module
(
gnu
packages
oggvorbis
)
#
:use-module
(
gnu
packages
openssl
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
video
)
#
:use-module
((
guix
licenses
)
#
:renamer
(
symbol-prefix-proc
'license:
))
#
:use-module
(
guix
packages
)
...
...
@@ -54,7 +56,6 @@ (define-public libextractor
;; The following dependencies are all optional, but should be
;; available for maximum coverage:
;; * libarchive
;; * libavutil / libavformat / libavcodec / libswscale (ffmpeg)
;; * libexiv2
;; * libgif (giflib)
;; * libgtk+ >= 3.0.0 (may probably drop glib then as a propagated input of
...
...
@@ -70,7 +71,10 @@ (define-public libextractor
(
inputs
`
((
"gettext"
,
gnu:gettext
)
(
"flac"
,
flac
)
(
"ffmpeg"
,
ffmpeg
)
(
"glib"
,
glib
)
(
"gstreamer"
,
gstreamer
)
(
"gst-plugins-base"
,
gst-plugins-base
)
(
"libjpeg"
,
libjpeg
)
(
"libogg"
,
libogg
)
(
"libtiff"
,
libtiff
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment