Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
2895a87f
Unverified
Commit
2895a87f
authored
5 years ago
by
John Soo
Committed by
Björn Höfling
5 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add libspnav.
* gnu/packages/engineering.scm (libspnav): New variable.
parent
2ea8b51a
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/engineering.scm
+36
-0
36 additions, 0 deletions
gnu/packages/engineering.scm
with
36 additions
and
0 deletions
gnu/packages/engineering.scm
+
36
−
0
View file @
2895a87f
...
...
@@ -13,6 +13,7 @@
;;; Copyright © 2019 Tim Stahel <swedneck@swedneck.xyz>
;;; Copyright © 2019 Jovany Leandro G.C <bit4bit@riseup.net>
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -2214,3 +2215,38 @@ (define-public openscad
full programmatic control over your models."
)
(
home-page
"https://www.openscad.org/"
)
(
license
license:gpl2+
)))
(
define-public
libspnav
(
package
(
name
"libspnav"
)
(
version
"0.2.3"
)
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
"https://github.com/FreeSpacenav/libspnav.git"
)
(
commit
(
string-append
"libspnav-"
version
))))
(
sha256
(
base32
"098h1jhlj87axpza5zgy58prp0zn94wyrbch6x0s7q4mzh7dc8ba"
))
(
file-name
(
git-file-name
name
version
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"libx11"
,
libx11
)))
(
arguments
`
(
#
:tests?
#f
))
(
home-page
"http://spacenav.sourceforge.net/"
)
(
synopsis
"Library for communicating with spacenavd or 3dxsrv"
)
(
description
"The libspnav library is provided as a replacement of the magellan
library. It provides a cleaner, and more orthogonal interface. libspnav
supports both the original X11 protocol for communicating with the driver, and
the new alternative non-X protocol. Programs that choose to use the X11
protocol, are automatically compatible with either the free spacenavd driver
or the official 3dxserv, as if they were using the magellan SDK.
Also, libspnav provides a magellan API wrapper on top of the new API. So, any
applications that were using the magellan library, can switch to libspnav
without any changes. And programmers that are familliar with the magellan API
can continue using it with a free library without the restrictions of the
official SDK."
)
(
license
license:bsd-3
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment