Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
28a1041f
Unverified
Commit
28a1041f
authored
7 years ago
by
Adriano Peluso
Committed by
Ricardo Wurmus
7 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add guile-miniadapton.
* gnu/packages/guile.scm (guile-miniadapton): New variable.
parent
180bd4a8
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/guile.scm
+69
-0
69 additions, 0 deletions
gnu/packages/guile.scm
with
69 additions
and
0 deletions
gnu/packages/guile.scm
+
69
−
0
View file @
28a1041f
...
...
@@ -32,6 +32,7 @@
(
define-module
(
gnu
packages
guile
)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
admin
)
;;for tree
#
:use-module
(
gnu
packages
aspell
)
#
:use-module
(
gnu
packages
bash
)
#
:use-module
(
gnu
packages
bdw-gc
)
...
...
@@ -794,6 +795,74 @@ (define-public guile-minikanren
(
define-public
guile2
.
2
-minikanren
(
package-for-guile-2
.
2
guile-minikanren
))
(
define-public
guile-miniadapton
(
let
((
commit
"1b5749422304567c96ac5367f2221dda9eff5880"
)
(
revision
"1"
))
(
package
(
name
"guile-miniadapton"
)
(
version
(
string-append
"0-"
revision
"."
(
string-take
commit
9
)))
(
source
(
origin
(
method
git-fetch
)
(
uri
(
git-reference
(
url
"https://github.com/fisherdj/miniAdapton.git"
)
(
commit
commit
)))
(
file-name
(
string-append
name
"-"
version
"-checkout"
))
(
sha256
(
base32
"09q51zkw2fypad5xixskfzw2cjhjgs5cswdp3i7cpp651rb3zndh"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:modules
((
guix
build
utils
)
(
ice-9
popen
)
(
ice-9
rdelim
)
(
srfi
srfi-1
)
(
guix
build
gnu-build-system
))
#
:tests?
#f
; there is no test target
#
:phases
(
modify-phases
%standard-phases
(
delete
'configure
)
(
delete
'build
)
(
replace
'install
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let*
((
cwd
(
getcwd
))
(
scm-files
(
find-files
"."
"\\.scm$"
))
(
effective
(
read-line
(
open-pipe*
OPEN_READ
"guile"
"-c"
"(display (effective-version))"
)))
(
module-dir
(
string-append
(
assoc-ref
outputs
"out"
)
"/share/guile/site/"
effective
)))
;; Make installation directories.
(
mkdir-p
module-dir
)
(
setenv
"GUILE_AUTO_COMPILE"
"0"
)
;; Compile .scm files and install.
(
every
(
lambda
(
file
)
(
let
((
go-file
(
string-append
module-dir
"/"
(
basename
file
".scm"
)
".go"
)))
;; Install source module.
(
install-file
file
module-dir
)
;; Compile and install module.
(
zero?
(
system*
"guild"
"compile"
"-L"
cwd
"-o"
go-file
file
))))
scm-files
)))))))
(
inputs
`
((
"guile"
,
guile-2
.
2
)))
(
home-page
"https://github.com/fisherdj/miniAdapton"
)
(
synopsis
"Minimal implementation of incremental computation in Guile
Scheme"
)
(
description
"This package provides a complete Scheme implementation of
miniAdapton, which implements the core functionality of the Adapton system for
incremental computation (also known as self-adjusting computation). Like
Adapton, miniAdapton allows programmers to safely combine mutation and
memoization. miniAdapton is built on top of an even simpler system,
microAdapton. Both miniAdapton and microAdapton are designed to be easy to
understand, extend, and port to host languages other than Scheme."
)
(
license
license:expat
))))
(
define-public
guile-irregex
(
package
(
name
"guile-irregex"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment