Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
2a1e82bb
Commit
2a1e82bb
authored
12 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add Perl XML::Parser.
* gnu/packages/xml.scm (perl-xml-parser): New variable.
parent
08fd1ebe
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/xml.scm
+33
-1
33 additions, 1 deletion
gnu/packages/xml.scm
with
33 additions
and
1 deletion
gnu/packages/xml.scm
+
33
−
1
View file @
2a1e82bb
...
@@ -26,7 +26,8 @@ (define-module (gnu packages xml)
...
@@ -26,7 +26,8 @@ (define-module (gnu packages xml)
#
:renamer
(
symbol-prefix-proc
'license:
))
#
:renamer
(
symbol-prefix-proc
'license:
))
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
gnu
))
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
perl
))
(
define-public
expat
(
define-public
expat
(
package
(
package
...
@@ -90,3 +91,34 @@ (define-public libxslt
...
@@ -90,3 +91,34 @@ (define-public libxslt
"Libxslt is an XSLT C library developed for the GNOME project. It is
"Libxslt is an XSLT C library developed for the GNOME project. It is
based on libxml for XML parsing, tree manipulation and XPath support."
)
based on libxml for XML parsing, tree manipulation and XPath support."
)
(
license
license:x11
)))
(
license
license:x11
)))
(
define-public
perl-xml-parser
(
package
(
name
"perl-xml-parser"
)
(
version
"2.41"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://cpan/authors/id/M/MS/MSERGEANT/XML-Parser-"
version
".tar.gz"
))
(
sha256
(
base32
"1sadi505g5qmxr36lgcbrcrqh3a5gcdg32b405gnr8k54b6rg0dl"
))))
(
build-system
perl-build-system
)
(
arguments
`
(
#
:make-maker-flags
(
let
((
expat
(
assoc-ref
%build-inputs
"expat"
)))
(
list
(
string-append
"EXPATLIBPATH="
expat
"/lib"
)
(
string-append
"EXPATINCPATH="
expat
"/include"
)))))
(
inputs
`
((
"expat"
,
expat
)))
(
license
(
package-license
perl
))
(
synopsis
"Perl bindings to the Expat XML parsing library"
)
(
description
"This module provides ways to parse XML documents. It is built on top of
XML::Parser::Expat, which is a lower level interface to James Clark's expat
library. Each call to one of the parsing methods creates a new instance of
XML::Parser::Expat which is then used to parse the document. Expat options
may be provided when the XML::Parser object is created. These options are
then passed on to the Expat object on each parse call. They can also be given
as extra arguments to the parse methods, in which case they override options
given at XML::Parser creation time."
)
(
home-page
"http://search.cpan.org/~toddr/XML-Parser-2.41/Parser.pm"
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment