Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
2cbede59
Unverified
Commit
2cbede59
authored
5 years ago
by
Julien Lepiller
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add offlate.
* gnu/packages/python-xyz.scm (offlate): New variable.
parent
7dec888f
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/python-xyz.scm
+45
-0
45 additions, 0 deletions
gnu/packages/python-xyz.scm
with
45 additions
and
0 deletions
gnu/packages/python-xyz.scm
+
45
−
0
View file @
2cbede59
...
@@ -97,6 +97,7 @@ (define-module (gnu packages python-xyz)
...
@@ -97,6 +97,7 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages crypto)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
#:use-module (gnu packages databases)
#:use-module (gnu packages dbm)
#:use-module (gnu packages dbm)
#:use-module (gnu packages enchant)
#:use-module (gnu packages file)
#:use-module (gnu packages file)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gcc)
...
@@ -17453,3 +17454,47 @@ (define-public python-watchdog
...
@@ -17453,3 +17454,47 @@ (define-public python-watchdog
such as a file modification and trigger an action. This is similar to inotify,
such as a file modification and trigger an action. This is similar to inotify,
but portable.")
but portable.")
(license license:asl2.0)))
(license license:asl2.0)))
(define-public offlate
(package
(name "offlate")
(version "0.5")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://framagit.org/tyreunom/offlate")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
"13pqnbl05wcyldfvl75fp89vjgwsvxyc69vhnb17kkha2rc2k1h7"))))
(build-system python-build-system)
(arguments
;; No tests
`(#:tests? #f))
(propagated-inputs
`(("python-android-stringslib" ,python-android-stringslib)
("python-dateutil" ,python-dateutil)
("python-gitlab" ,python-gitlab)
("python-lxml" ,python-lxml)
("python-polib" ,python-polib)
("python-pyenchant" ,python-pyenchant)
("python-pygit2" ,python-pygit2)
("python-pygithub" ,python-pygithub)
("python-pyqt" ,python-pyqt)
("python-requests" ,python-requests)
("python-ruamel.yaml" ,python-ruamel.yaml)
("python-translation-finder" ,python-translation-finder)
("python-watchdog" ,python-watchdog)))
(native-inputs
`(("qttools" ,qttools)))
(home-page "https://framagit.org/tyreunom/offlate")
(synopsis "Offline translation interface for online translation tools")
(description "Offlate offers a unified interface for different translation
file formats, as well as many different online translation platforms. You can
use it to get work from online platforms, specialized such as the Translation
Project, or not such a gitlab instance when your upstream doesn't use any
dedicated platform. The tool proposes a unified interface for any format and
an upload option to send your work back to the platform.")
(license license:gpl3+)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment