Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
2d0fd07b
Commit
2d0fd07b
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add Pure Data.
* gnu/packages/music.scm (pd): New variable.
parent
9a59673d
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/music.scm
+58
-1
58 additions, 1 deletion
gnu/packages/music.scm
with
58 additions
and
1 deletion
gnu/packages/music.scm
+
58
−
1
View file @
2d0fd07b
...
...
@@ -27,6 +27,7 @@ (define-module (gnu packages music)
#
:use-module
(
guix
build-system
waf
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
audio
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
base
)
;libbdf
#
:use-module
(
gnu
packages
boost
)
#
:use-module
(
gnu
packages
bison
)
...
...
@@ -60,12 +61,14 @@ (define-module (gnu packages music)
#
:use-module
(
gnu
packages
qt
)
#
:use-module
(
gnu
packages
rdf
)
#
:use-module
(
gnu
packages
rsync
)
#
:use-module
(
gnu
packages
tcl
)
#
:use-module
(
gnu
packages
texinfo
)
#
:use-module
(
gnu
packages
texlive
)
#
:use-module
(
gnu
packages
web
)
#
:use-module
(
gnu
packages
xml
)
#
:use-module
(
gnu
packages
xiph
)
#
:use-module
(
gnu
packages
zip
))
#
:use-module
(
gnu
packages
zip
)
#
:use-module
((
srfi
srfi-1
)
#
:select
(
last
)))
(
define-public
hydrogen
(
package
...
...
@@ -590,3 +593,57 @@ (define-public tuxguitar
tuplets, time signature management, tempo management, gp3/gp4/gp5 import and
export."
)
(
license
license:lgpl2
.
1
+
)))
(
define-public
pd
(
package
(
name
"pd"
)
(
version
"0.45.4"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/pure-data/pure-data/"
version
"/pd-"
(
version-major+minor
version
)
"-"
(
last
(
string-split
version
#\.
))
".src.tar.gz"
))
(
sha256
(
base32
"1ls2ap5yi2zxvmr247621g4jx0hhfds4j5704a050bn2n3l0va2p"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:tests?
#f
; no "check" target
#
:phases
(
modify-phases
%standard-phases
(
add-before
'configure
'fix-wish-path
(
lambda
_
(
substitute*
"src/s_inter.c"
((
" wish "
)
(
string-append
" "
(
which
"wish8.6"
)
" "
)))
(
substitute*
"tcl/pd-gui.tcl"
((
"exec wish "
)
(
string-append
"exec "
(
which
"wish8.6"
)
" "
)))
#t
))
(
add-after
'unpack
'autoconf
(
lambda
_
(
zero?
(
system*
"autoreconf"
"-vfi"
)))))))
(
native-inputs
`
((
"autoconf"
,
autoconf
)
(
"automake"
,
automake
)
(
"libtool"
,
libtool
)
(
"gettext"
,
gnu-gettext
)
(
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"tk"
,
tk
)
(
"alsa-lib"
,
alsa-lib
)
(
"jack"
,
jack-1
)))
(
home-page
"http://puredata.info"
)
(
synopsis
"Visual programming language for artistic performances"
)
(
description
"Pure Data (aka Pd) is a visual programming language. Pd enables
musicians, visual artists, performers, researchers, and developers to create
software graphically, without writing lines of code. Pd is used to process
and generate sound, video, 2D/3D graphics, and interface sensors, input
devices, and MIDI. Pd can easily work over local and remote networks to
integrate wearable technology, motor systems, lighting rigs, and other
equipment. Pd is suitable for learning basic multimedia processing and visual
programming methods as well as for realizing complex systems for large-scale
projects."
)
(
license
license:bsd-3
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment