Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
2d656a93
Unverified
Commit
2d656a93
authored
8 years ago
by
Leo Famulari
Browse files
Options
Downloads
Patches
Plain Diff
Revert "gnu: gnutls: Fix test failure."
This reverts commit
1d14bf9f
.
parent
27326064
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
gnu/local.mk
+0
-1
0 additions, 1 deletion
gnu/local.mk
gnu/packages/patches/gnutls-fix-stale-test.patch
+0
-50
0 additions, 50 deletions
gnu/packages/patches/gnutls-fix-stale-test.patch
gnu/packages/tls.scm
+0
-8
0 additions, 8 deletions
gnu/packages/tls.scm
with
0 additions
and
59 deletions
gnu/local.mk
+
0
−
1
View file @
2d656a93
...
@@ -534,7 +534,6 @@ dist_patch_DATA = \
...
@@ -534,7 +534,6 @@ dist_patch_DATA = \
%D%/packages/patches/gmp-faulty-test.patch
\
%D%/packages/patches/gmp-faulty-test.patch
\
%D%/packages/patches/gnome-tweak-tool-search-paths.patch
\
%D%/packages/patches/gnome-tweak-tool-search-paths.patch
\
%D%/packages/patches/gnucash-price-quotes-perl.patch
\
%D%/packages/patches/gnucash-price-quotes-perl.patch
\
%D%/packages/patches/gnutls-fix-stale-test.patch
\
%D%/packages/patches/gobject-introspection-absolute-shlib-path.patch
\
%D%/packages/patches/gobject-introspection-absolute-shlib-path.patch
\
%D%/packages/patches/gobject-introspection-cc.patch
\
%D%/packages/patches/gobject-introspection-cc.patch
\
%D%/packages/patches/gobject-introspection-girepository.patch
\
%D%/packages/patches/gobject-introspection-girepository.patch
\
...
...
This diff is collapsed.
Click to expand it.
gnu/packages/patches/gnutls-fix-stale-test.patch
deleted
100644 → 0
+
0
−
50
View file @
27326064
A certificate used in the GnuTLS test suite has expired, causing the
test suite to fail.
The effect of this patch depends on whether or not the datefudge program
is available. If it is, then it is used to change the date in the test
environment. If it is not, then the test is skipped.
At the time this patch was added to Guix, datefudge was not available,
so the test is skipped.
Taken from upstream commit:
https://gitlab.com/gnutls/gnutls/commit/47f25d9e08d4e102572804a2aed186b01db23c65
From 47f25d9e08d4e102572804a2aed186b01db23c65 Mon Sep 17 00:00:00 2001
From: Nikos Mavrogiannopoulos <nmav@redhat.com>
Date: Wed, 29 Jun 2016 17:31:13 +0200
Subject: [PATCH] tests: use datefudge in name-constraints test
This avoids the expiration of the used certificate to affect the test.
---
tests/cert-tests/name-constraints | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)
diff --git a/tests/cert-tests/name-constraints b/tests/cert-tests/name-constraints
index 05d6e9b..59af00f 100755
--- a/tests/cert-tests/name-constraints
+++ b/tests/cert-tests/name-constraints
@@ -28,7 +28,18 @@
if ! test -z "${VALGRIND}"; then
fi
TMPFILE=tmp.$$.pem
-${VALGRIND} "${CERTTOOL}" -e --infile "${srcdir}/name-constraints-ip.pem"
+export TZ="UTC"
+
+# Check for datefudge
+TSTAMP=`datefudge -s "2006-09-23" date -u +%s || true`
+if test "$TSTAMP" != "1158969600"; then
+ echo $TSTAMP
+ echo "You need datefudge to run this test"
+ exit 77
+fi
+
+datefudge -s "2016-04-22" \
+ ${VALGRIND} "${CERTTOOL}" -e --infile "${srcdir}/name-constraints-ip.pem"
rc=$?
if test "${rc}" != "0"; then
--
2.9.1
This diff is collapsed.
Click to expand it.
gnu/packages/tls.scm
+
0
−
8
View file @
2d656a93
...
@@ -122,7 +122,6 @@ (define-public p11-kit
...
@@ -122,7 +122,6 @@ (define-public p11-kit
(
define-public
gnutls
(
define-public
gnutls
(
package
(
package
(
name
"gnutls"
)
(
name
"gnutls"
)
(
replacement
gnutls/fixed
)
(
version
"3.4.7"
)
(
version
"3.4.7"
)
(
source
(
origin
(
source
(
origin
(
method
url-fetch
)
(
method
url-fetch
)
...
@@ -195,13 +194,6 @@ (define-public gnutls
...
@@ -195,13 +194,6 @@ (define-public gnutls
(
properties
'
((
ftp-server
.
"ftp.gnutls.org"
)
(
properties
'
((
ftp-server
.
"ftp.gnutls.org"
)
(
ftp-directory
.
"/gcrypt/gnutls"
)))))
(
ftp-directory
.
"/gcrypt/gnutls"
)))))
(
define-public
gnutls/fixed
(
package
(
inherit
gnutls
)
(
source
(
origin
(
inherit
(
package-source
gnutls
))
(
patches
(
search-patches
"gnutls-fix-stale-test.patch"
))))))
(
define-public
openssl
(
define-public
openssl
(
package
(
package
(
name
"openssl"
)
(
name
"openssl"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment