Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
2ee8869a
Commit
2ee8869a
authored
10 years ago
by
Federico Beffa
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add numpy.
* gnu/packages/python.scm (python-numpy, python2-numpy): New variables.
parent
4cdec09a
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/python.scm
+71
-0
71 additions, 0 deletions
gnu/packages/python.scm
with
71 additions
and
0 deletions
gnu/packages/python.scm
+
71
−
0
View file @
2ee8869a
...
@@ -46,6 +46,8 @@ (define-module (gnu packages python)
...
@@ -46,6 +46,8 @@ (define-module (gnu packages python)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
imagemagick
)
#
:use-module
(
gnu
packages
imagemagick
)
#
:use-module
(
gnu
packages
fontutils
)
#
:use-module
(
gnu
packages
fontutils
)
#
:use-module
(
gnu
packages
which
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
utils
)
#
:use-module
(
guix
utils
)
...
@@ -1939,6 +1941,75 @@ (define python-numpy-bootstrap
...
@@ -1939,6 +1941,75 @@ (define python-numpy-bootstrap
(
define
python2-numpy-bootstrap
(
define
python2-numpy-bootstrap
(
package-with-python2
python-numpy-bootstrap
))
(
package-with-python2
python-numpy-bootstrap
))
(
define-public
python-numpy
(
package
(
inherit
python-numpy-bootstrap
)
(
name
"python-numpy"
)
(
outputs
'
(
"out"
"doc"
))
(
inputs
`
((
"which"
,
which
)
(
"python-setuptools"
,
python-setuptools
)
(
"python-matplotlib"
,
python-matplotlib
)
(
"python-sphinx"
,
python-sphinx
)
(
"python-pyparsing"
,
python-pyparsing
)
(
"python-numpydoc"
,
python-numpydoc
)
,@
(
package-inputs
python-numpy-bootstrap
)))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"texlive"
,
texlive
)
(
"texinfo"
,
texinfo
)
(
"perl"
,
perl
)
,@
(
package-native-inputs
python-numpy-bootstrap
)))
(
arguments
`
(
,@
(
substitute-keyword-arguments
(
package-arguments
python-numpy-bootstrap
)
((
#
:phases
phases
)
`
(
alist-cons-after
'install
'install-doc
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let*
((
data
(
string-append
(
assoc-ref
outputs
"doc"
)
"/share"
))
(
doc
(
string-append
data
"/doc/"
,
name
"-"
,
(
package-version
python-numpy-bootstrap
)))
(
info
(
string-append
data
"/info"
))
(
html
(
string-append
doc
"/html"
))
(
pyver
,
(
string-append
"PYVER="
)))
(
with-directory-excursion
"doc"
(
mkdir-p
html
)
(
system*
"make"
"html"
pyver
)
(
system*
"make"
"latex"
"PAPER=a4"
pyver
)
(
system*
"make"
"-C"
"build/latex"
"all-pdf"
"PAPER=a4"
pyver
)
;; FIXME: Generation of the info file fails.
;; (system* "make" "info" pyver)
;; (mkdir-p info)
;; (copy-file "build/texinfo/numpy.info"
;; (string-append info "/numpy.info"))
(
for-each
(
lambda
(
file
)
(
copy-file
(
string-append
"build/latex"
file
)
(
string-append
doc
file
)))
'
(
"/numpy-ref.pdf"
"/numpy-user.pdf"
))
(
with-directory-excursion
"build/html"
(
for-each
(
lambda
(
file
)
(
let*
((
dir
(
dirname
file
))
(
tgt-dir
(
string-append
html
"/"
dir
)))
(
unless
(
equal?
"."
dir
)
(
mkdir-p
tgt-dir
))
(
copy-file
file
(
string-append
html
"/"
file
))))
(
find-files
"."
".*"
))))))
,
phases
)))))))
(
define-public
python2-numpy
(
let
((
numpy
(
package-with-python2
python-numpy
)))
(
package
(
inherit
numpy
)
;; Make sure we use exactly PYTHON2-NUMPYDOC, which is customized for
;; Python 2. Since it is also an input to PYTHON2-MATPLOTLIB, we need to
;; import the right version of 'matplotlib' as well.
(
inputs
`
((
"python2-numpydoc"
,
python2-numpydoc
)
(
"python2-matplotlib"
,
python2-matplotlib
)
,@
(
alist-delete
"python-numpydoc"
(
alist-delete
"python-matplotlib"
(
package-inputs
numpy
))))))))
(
define-public
python-pyparsing
(
define-public
python-pyparsing
(
package
(
package
(
name
"python-pyparsing"
)
(
name
"python-pyparsing"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment