Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
307ad140
Commit
307ad140
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add MLT.
* gnu/packages/video.scm (mlt): New variable.
parent
56196594
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/video.scm
+51
-0
51 additions, 0 deletions
gnu/packages/video.scm
with
51 additions
and
0 deletions
gnu/packages/video.scm
+
51
−
0
View file @
307ad140
...
@@ -5,6 +5,7 @@
...
@@ -5,6 +5,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2015 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -1196,3 +1197,53 @@ (define-public livestreamer
...
@@ -1196,3 +1197,53 @@ (define-public livestreamer
from various services and pipes them into a video playing application."
)
from various services and pipes them into a video playing application."
)
(
home-page
"http://livestreamer.io/"
)
(
home-page
"http://livestreamer.io/"
)
(
license
license:bsd-2
)))
(
license
license:bsd-2
)))
(
define-public
mlt
(
package
(
name
"mlt"
)
(
version
"0.9.8"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/mlt/mlt/mlt-"
version
".tar.gz"
))
(
sha256
(
base32
"0rmrkj7z9g3nr4099f3ff0r14l3ixcfnlx2cdbkqa6pxin0pv9bz"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:tests?
#f
; no tests
#
:make-flags
'
(
"CC=gcc"
)
#
:configure-flags
(
list
"--enable-gpl3"
"--enable-gpl"
)
#
:phases
(
modify-phases
%standard-phases
(
add-after
'configure
'override-LDFLAGS
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
substitute*
"config.mak"
((
"LDFLAGS\\+="
)
(
string-append
"LDFLAGS+=-Wl,-rpath="
(
assoc-ref
outputs
"out"
)
"/lib "
)))
#t
)))))
(
inputs
`
((
"alsa-lib"
,
alsa-lib
)
(
"fftw"
,
fftw
)
(
"libxml2"
,
libxml2
)
(
"jack"
,
jack-1
)
(
"ladspa"
,
ladspa
)
(
"libsamplerate"
,
libsamplerate
)
(
"sdl"
,
sdl
)
(
"sox"
,
sox
)))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
home-page
"http://www.mltframework.org/"
)
(
synopsis
"Author, manage, and run multitrack audio/video compositions"
)
(
description
"MLT is a multimedia framework, designed and developed for television
broadcasting. It provides a toolkit for broadcasters, video editors, media
players, transcoders, web streamers and many more types of applications. The
functionality of the system is provided via an assortment of ready to use
tools, XML authoring components, and an extensible plug-in based API."
)
(
license
license:lgpl2
.
1
+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment