Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
3420c905
Unverified
Commit
3420c905
authored
7 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add gess.
* gnu/packages/bioinformatics.scm (gess): New variable.
parent
44f6c889
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/bioinformatics.scm
+61
-0
61 additions, 0 deletions
gnu/packages/bioinformatics.scm
with
61 additions
and
0 deletions
gnu/packages/bioinformatics.scm
+
61
−
0
View file @
3420c905
...
...
@@ -9328,3 +9328,64 @@ (define-public trim-galore
adapter trimming as well as quality control, with some added functionality to
remove biased methylation positions for RRBS sequence files."
)
(
license
license:gpl3+
)))
(
define-public
gess
(
package
(
name
"gess"
)
(
version
"1.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://compbio.uthscsa.edu/"
"GESS_Web/files/"
"gess-"
version
".src.tar.gz"
))
(
sha256
(
base32
"0hyk403kxscclzfs24pvdgiv0wm03kjcziqdrp5w46cb049gz0d7"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:tests?
#f
; no tests
#
:phases
(
modify-phases
%standard-phases
(
delete
'configure
)
(
delete
'build
)
(
replace
'install
(
lambda*
(
#
:key
inputs
outputs
#
:allow-other-keys
)
(
let*
((
python
(
assoc-ref
inputs
"python"
))
(
out
(
assoc-ref
outputs
"out"
))
(
bin
(
string-append
out
"/bin/"
))
(
target
(
string-append
out
"/lib/python2.7/site-packages/gess/"
)))
(
mkdir-p
target
)
(
copy-recursively
"."
target
)
;; Make GESS.py executable
(
chmod
(
string-append
target
"GESS.py"
)
#o555
)
;; Add Python shebang to the top and make Matplotlib
;; usable.
(
substitute*
(
string-append
target
"GESS.py"
)
((
"\"\"\"Description:"
line
)
(
string-append
"#!"
(
which
"python"
)
"
import matplotlib
matplotlib.use('Agg')
"
line
)))
;; Make sure GESS has all modules in its path
(
wrap-program
(
string-append
target
"GESS.py"
)
`
(
"PYTHONPATH"
":"
prefix
(
,target
,
(
getenv
"PYTHONPATH"
))))
(
mkdir-p
bin
)
(
symlink
(
string-append
target
"GESS.py"
)
(
string-append
bin
"GESS.py"
))
#t
))))))
(
inputs
`
((
"python"
,
python-2
)
(
"python2-pysam"
,
python2-pysam
)
(
"python2-scipy"
,
python2-scipy
)
(
"python2-numpy"
,
python2-numpy
)
(
"python2-networkx"
,
python2-networkx
)
(
"python2-biopython"
,
python2-biopython
)))
(
home-page
"http://compbio.uthscsa.edu/GESS_Web/"
)
(
synopsis
"Detect exon-skipping events from raw RNA-seq data"
)
(
description
"GESS is an implementation of a novel computational method to detect de
novo exon-skipping events directly from raw RNA-seq data without the prior
knowledge of gene annotation information. GESS stands for the graph-based
exon-skipping scanner detection scheme."
)
(
license
license:bsd-3
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment