Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
34316794
Unverified
Commit
34316794
authored
4 years ago
by
Tobias Geerinckx-Rice
Browse files
Options
Downloads
Patches
Plain Diff
gnu: discount: Update to 2.2.7.
* gnu/packages/markup.scm (discount): Update to 2.2.7.
parent
f41b56a9
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/markup.scm
+11
-7
11 additions, 7 deletions
gnu/packages/markup.scm
with
11 additions
and
7 deletions
gnu/packages/markup.scm
+
11
−
7
View file @
34316794
...
@@ -3,7 +3,7 @@
...
@@ -3,7 +3,7 @@
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2018, 2019
, 2020
Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
...
@@ -113,7 +113,7 @@ (define-public markdown
...
@@ -113,7 +113,7 @@ (define-public markdown
(
define-public
discount
(
define-public
discount
(
package
(
package
(
name
"discount"
)
(
name
"discount"
)
(
version
"2.2.
4
"
)
(
version
"2.2.
7
"
)
(
source
(
origin
(
source
(
origin
(
method
url-fetch
)
(
method
url-fetch
)
(
uri
(
string-append
(
uri
(
string-append
...
@@ -121,10 +121,11 @@ (define-public discount
...
@@ -121,10 +121,11 @@ (define-public discount
"discount/discount-"
version
".tar.bz2"
))
"discount/discount-"
version
".tar.bz2"
))
(
sha256
(
sha256
(
base32
(
base32
"
199hwajpspqil0a4y3yxsmhdp2dm
73
g
qk
zfk4mrwzsmlq8y1xzbl
"
))))
"
024mxv0gpvilyfczarcgy5m7h4lv6qvhjfpf5i
73qk
xhszjjn9mi
"
))))
(
build-system
gnu-build-system
)
(
build-system
gnu-build-system
)
(
arguments
(
arguments
`
(
#
:test-target
"test"
`
(
#
:test-target
"test"
#
:parallel-build?
#f
; libmarkdown won't be built in time
#
:make-flags
(
list
#
:make-flags
(
list
(
string-append
"LFLAGS=-L. -Wl,-rpath="
(
string-append
"LFLAGS=-L. -Wl,-rpath="
(
assoc-ref
%outputs
"out"
)
"/lib"
))
(
assoc-ref
%outputs
"out"
)
"/lib"
))
...
@@ -139,10 +140,13 @@ (define-public discount
...
@@ -139,10 +140,13 @@ (define-public discount
#t
))
#t
))
(
replace
'configure
(
replace
'configure
(
lambda*
(
#
:key
inputs
outputs
#
:allow-other-keys
)
(
lambda*
(
#
:key
inputs
outputs
#
:allow-other-keys
)
(
setenv
"CC"
,
(
cc-for-target
))
(
let
((
out
(
assoc-ref
outputs
"out"
)))
(
invoke
"./configure.sh"
(
setenv
"CC"
,
(
cc-for-target
))
(
string-append
"--prefix="
(
assoc-ref
outputs
"out"
))
;; The ‘validate-runpath’ phase fails otherwise.
"--shared"
))))))
(
setenv
"LDFLAGS"
(
string-append
"-Wl,-rpath="
out
"/lib"
))
(
invoke
"./configure.sh"
(
string-append
"--prefix="
out
)
"--shared"
)))))))
(
synopsis
"Markdown processing library, written in C"
)
(
synopsis
"Markdown processing library, written in C"
)
(
description
(
description
"Discount is a markdown implementation, written in C. It provides a
"Discount is a markdown implementation, written in C. It provides a
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment