Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
35de1fbd
Commit
35de1fbd
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add python-seaborn.
* gnu/packages/python.scm (python-seaborn, python2-seaborn): New variables.
parent
d072efcb
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/python.scm
+35
-0
35 additions, 0 deletions
gnu/packages/python.scm
with
35 additions
and
0 deletions
gnu/packages/python.scm
+
35
−
0
View file @
35de1fbd
...
@@ -3523,6 +3523,41 @@ (define-public snakemake
...
@@ -3523,6 +3523,41 @@ (define-public snakemake
Python style, together with a fast and comfortable execution environment."
)
Python style, together with a fast and comfortable execution environment."
)
(
license
license:expat
)))
(
license
license:expat
)))
(
define-public
python-seaborn
(
package
(
name
"python-seaborn"
)
(
version
"0.5.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://pypi.python.org/packages/source/s/seaborn/seaborn-"
version
".tar.gz"
))
(
sha256
(
base32
"1236abw18ijjglmv60q85ckqrvgf5qyy4zlq7nz5aqfg6q87z3wc"
))))
(
build-system
python-build-system
)
(
propagated-inputs
`
((
"python-pandas"
,
python-pandas
)
(
"python-matplotlib"
,
python-matplotlib
)
(
"python-scipy"
,
python-scipy
)))
(
native-inputs
`
((
"python-setuptools"
,
python-setuptools
)))
(
home-page
"http://stanford.edu/~mwaskom/software/seaborn/"
)
(
synopsis
"Statistical data visualization"
)
(
description
"Seaborn is a library for making attractive and informative statistical
graphics in Python. It is built on top of matplotlib and tightly integrated
with the PyData stack, including support for numpy and pandas data structures
and statistical routines from scipy and statsmodels."
)
(
license
bsd-3
)))
(
define-public
python2-seaborn
(
let
((
seaborn
(
package-with-python2
python-seaborn
)))
(
package
(
inherit
seaborn
)
(
propagated-inputs
`
((
"python2-pytz"
,
python2-pytz
)
,@
(
package-propagated-inputs
seaborn
))))))
(
define-public
python-sympy
(
define-public
python-sympy
(
package
(
package
(
name
"python-sympy"
)
(
name
"python-sympy"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment