Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
380c65de
Unverified
Commit
380c65de
authored
7 years ago
by
Julien Lepiller
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add coq-mathcomp.
* gnu/packages/ocaml.scm (coq-mathcomp): New variable.
parent
88191ace
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ocaml.scm
+42
-0
42 additions, 0 deletions
gnu/packages/ocaml.scm
with
42 additions
and
0 deletions
gnu/packages/ocaml.scm
+
42
−
0
View file @
380c65de
...
...
@@ -3253,3 +3253,45 @@ (define-public coq-gappa
software verification plateform or as an automatic tactic for the Coq proof
assistant."
)
(
license
(
list
license:gpl2+
license:cecill
))))
;either gpl2+ or cecill
(
define-public
coq-mathcomp
(
package
(
name
"coq-mathcomp"
)
(
version
"1.6.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/math-comp/math-comp/archive/mathcomp-"
version
".tar.gz"
))
(
sha256
(
base32
"1j9ylggjzrxz1i2hdl2yhsvmvy5z6l4rprwx7604401080p5sgjw"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"ocaml"
,
ocaml
)
(
"which"
,
which
)
(
"coq"
,
coq
)))
(
arguments
`
(
#
:tests?
#f
; No need to test formally-verified programs :)
#
:phases
(
modify-phases
%standard-phases
(
delete
'configure
)
(
add-before
'build
'chdir
(
lambda
_
(
chdir
"mathcomp"
)))
(
replace
'install
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
setenv
"COQLIB"
(
string-append
(
assoc-ref
outputs
"out"
)
"/lib/coq/"
))
(
zero?
(
system*
"make"
"-f"
"Makefile.coq"
(
string-append
"COQLIB="
(
assoc-ref
outputs
"out"
)
"/lib/coq/"
)
"install"
)))))))
(
home-page
"https://math-comp.github.io/math-comp/"
)
(
synopsis
"Mathematical Components for Coq"
)
(
description
"Mathematical Components for Coq has its origins in the formal
proof of the Four Colour Theorem. Since then it has grown to cover many areas
of mathematics and has been used for large scale projects like the formal proof
of the Odd Order Theorem.
The library is written using the Ssreflect proof language that is an integral
part of the distribution."
)
(
license
license:cecill-b
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment