Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
38efbcbb
Unverified
Commit
38efbcbb
authored
8 years ago
by
Manolis Ragkousis
Browse files
Options
Downloads
Patches
Plain Diff
gnu: hurd: Add hurd-core-headers package.
* gnu/packages/hurd.scm (hurd-core-headers): New variable.
parent
4791876c
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/hurd.scm
+27
-1
27 additions, 1 deletion
gnu/packages/hurd.scm
with
27 additions
and
1 deletion
gnu/packages/hurd.scm
+
27
−
1
View file @
38efbcbb
;;; GNU Guix --- Functional package management for GNU
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2014, 2015
, 2016
Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -22,6 +22,7 @@ (define-module (gnu packages hurd)
...
@@ -22,6 +22,7 @@ (define-module (gnu packages hurd)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
trivial
)
#
:use-module
(
gnu
packages
flex
)
#
:use-module
(
gnu
packages
flex
)
#
:use-module
(
gnu
packages
bison
)
#
:use-module
(
gnu
packages
bison
)
#
:use-module
(
gnu
packages
perl
)
#
:use-module
(
gnu
packages
perl
)
...
@@ -185,3 +186,28 @@ (define-public hurd-minimal
...
@@ -185,3 +186,28 @@ (define-public hurd-minimal
"This package provides libihash, needed to build the GNU C
"This package provides libihash, needed to build the GNU C
Library for GNU/Hurd."
)
Library for GNU/Hurd."
)
(
license
gpl2+
)))
(
license
gpl2+
)))
(
define-public
hurd-core-headers
(
package
(
name
"hurd-core-headers"
)
(
version
(
package-version
hurd-headers
))
(
source
#f
)
(
build-system
trivial-build-system
)
(
arguments
'
(
#
:modules
((
guix
build
union
))
#
:builder
(
begin
(
use-modules
(
ice-9
match
)
(
guix
build
union
))
(
match
%build-inputs
(((
names
.
directories
)
...
)
(
union-build
(
assoc-ref
%outputs
"out"
)
directories
))))))
(
inputs
`
((
"gnumach-headers"
,
gnumach-headers
)
(
"hurd-headers"
,
hurd-headers
)
(
"hurd-minimal"
,
hurd-minimal
)))
(
synopsis
"Union of the Hurd headers and libraries"
)
(
description
"This package contains the union of the Mach and Hurd headers and the
Hurd-minimal package which are needed for both glibc and GCC."
)
(
home-page
(
package-home-page
hurd-headers
))
(
license
(
package-license
hurd-headers
))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment