Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
3d4f9d5c
Commit
3d4f9d5c
authored
9 years ago
by
Christine Lemmer-Webber
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add assword.
* gnu/packages/password-utils.scm (assword): New variable.
parent
0bdc1671
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/password-utils.scm
+57
-1
57 additions, 1 deletion
gnu/packages/password-utils.scm
with
57 additions
and
1 deletion
gnu/packages/password-utils.scm
+
57
−
1
View file @
3d4f9d5c
...
@@ -2,6 +2,7 @@
...
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -26,13 +27,17 @@ (define-module (gnu packages password-utils)
...
@@ -26,13 +27,17 @@ (define-module (gnu packages password-utils)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
gnu
packages
compression
)
#
:use-module
(
gnu
packages
compression
)
#
:use-module
(
gnu
packages
gnupg
)
#
:use-module
(
gnu
packages
gnupg
)
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
guile
)
#
:use-module
(
gnu
packages
guile
)
#
:use-module
(
gnu
packages
man
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
python
)
#
:use-module
(
gnu
packages
tls
)
#
:use-module
(
gnu
packages
tls
)
#
:use-module
(
gnu
packages
qt
)
#
:use-module
(
gnu
packages
qt
)
#
:use-module
(
gnu
packages
xdisorg
)
#
:use-module
(
gnu
packages
xdisorg
)
#
:use-module
(
gnu
packages
xorg
))
#
:use-module
(
gnu
packages
xorg
)
#
:use-module
(
guix
build-system
python
))
(
define-public
pwgen
(
define-public
pwgen
(
package
(
package
...
@@ -185,3 +190,54 @@ (define-public libpwquality
...
@@ -185,3 +190,54 @@ (define-public libpwquality
"Libpwquality is a library for password quality checking and generation of
"Libpwquality is a library for password quality checking and generation of
random passwords that pass the checks."
)
random passwords that pass the checks."
)
(
license
license:gpl2+
)))
(
license
license:gpl2+
)))
(
define-public
assword
(
package
(
name
"assword"
)
(
version
"0.8"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
list
(
string-append
"http://http.debian.net/debian/pool/main/a/assword/"
"assword_"
version
".orig.tar.gz"
)))
(
sha256
(
base32
"0dl4wizbi0r21wxzykm8s445xbvqim5nabi799dmpkdnnh8i546i"
))))
(
arguments
`
(
#
:python
,
python-2
;; irritatingly, tests do run but not there are two problems:
;; - "import gtk" fails for unknown reasons here despite it the
;; program working (indeed, I've found I have to do a logout and log
;; back in in after an install order for some mumbo jumbo environment
;; variable mess to work with pygtk and assword... what's up with
;; that?)
;; - even when the tests fail, they don't return a nonzero status,
;; so I'm not sure how to programmatically get that information
#
:tests?
#f
#
:phases
(
modify-phases
%standard-phases
(
add-after
'install
'manpage
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
and
(
zero?
(
system*
"make"
"assword.1"
))
(
install-file
"assword.1"
(
string-append
(
assoc-ref
outputs
"out"
)
"/share/man/man1"
))))))))
(
build-system
python-build-system
)
(
native-inputs
`
((
"help2man"
,
help2man
)))
(
inputs
`
((
"python-setuptools"
,
python2-setuptools
)
(
"python2-xdo"
,
python2-xdo
)
(
"python2-pygpgme"
,
python2-pygpgme
)
(
"python2-pygtk"
,
python2-pygtk
)))
(
propagated-inputs
`
((
"xclip"
,
xclip
)))
(
home-page
"https://finestructure.net/assword/"
)
(
synopsis
"Password manager"
)
(
description
"assword is a simple password manager using GPG-wrapped
JSON files. It has a command line interface as well as a very simple
graphical interface, which can even \"type\" your passwords into
any X11 window."
)
(
license
license:gpl3+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment