Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
3d7a157c
Commit
3d7a157c
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add audit.
* gnu/packages/admin.scm (audit): New variable.
parent
fdc1b2fd
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/admin.scm
+40
-0
40 additions, 0 deletions
gnu/packages/admin.scm
with
40 additions
and
0 deletions
gnu/packages/admin.scm
+
40
−
0
View file @
3d7a157c
...
@@ -8,6 +8,7 @@
...
@@ -8,6 +8,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -36,6 +37,7 @@ (define-module (gnu packages admin)
...
@@ -36,6 +37,7 @@ (define-module (gnu packages admin)
#
:use-module
(
guix
build-system
trivial
)
#
:use-module
(
guix
build-system
trivial
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
cyrus-sasl
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
readline
)
#
:use-module
(
gnu
packages
readline
)
#
:use-module
(
gnu
packages
linux
)
#
:use-module
(
gnu
packages
linux
)
...
@@ -49,6 +51,7 @@ (define-module (gnu packages admin)
...
@@ -49,6 +51,7 @@ (define-module (gnu packages admin)
#
:use-module
(
gnu
packages
bison
)
#
:use-module
(
gnu
packages
bison
)
#
:use-module
(
gnu
packages
flex
)
#
:use-module
(
gnu
packages
flex
)
#
:use-module
(
gnu
packages
glib
)
#
:use-module
(
gnu
packages
glib
)
#
:use-module
(
gnu
packages
openldap
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
popt
)
#
:use-module
(
gnu
packages
popt
)
#
:use-module
(
gnu
packages
texinfo
)
#
:use-module
(
gnu
packages
texinfo
)
...
@@ -1456,3 +1459,40 @@ (define-public munge
...
@@ -1456,3 +1459,40 @@ (define-public munge
credentials without the use of root privileges, reserved ports, or
credentials without the use of root privileges, reserved ports, or
platform-specific methods."
)
platform-specific methods."
)
(
license
license:gpl3+
)))
(
license
license:gpl3+
)))
(
define-public
audit
(
package
(
name
"audit"
)
(
version
"2.4.5"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://people.redhat.com/sgrubb/audit/"
"audit-"
version
".tar.gz"
))
(
sha256
(
base32
"1q1q51dvxscbi4kbakmd4bn0xrvwwaiwvaya79925cbrqwzxsg77"
))))
(
build-system
gnu-build-system
)
(
home-page
"http://people.redhat.com/sgrubb/audit/"
)
(
arguments
`
(
#
:configure-flags
(
list
"--with-python=no"
)
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'fix-tests
(
lambda
_
;; In the build environmnte /etc/passwd does not contain an entry
;; for root/0, so we have to patch the expected value.
(
substitute*
"auparse/test/auparse_test.ref"
((
"=0 \\(root\\)"
)
"=0 (unknown(0))"
))
#t
)))))
(
inputs
`
((
"openldap"
,
openldap
)
(
"openssl"
,
openssl
)
(
"sasl"
,
cyrus-sasl
)))
(
synopsis
"User-space component to the Linux auditing system"
)
(
description
"auditd is the user-space component to the Linux auditing system, which
allows logging of system calls made by user-land processes. It's responsible
for writing audit records to the disk. Viewing the logs is done with the
@code{ausearch} or @code{aureport} utilities. Configuring the audit rules is
done with the @code{auditctl} utility."
)
(
license
license:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment