Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
3da5dca3
Commit
3da5dca3
authored
10 years ago
by
David Thompson
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add abbaye.
* gnu/packages/games.scm (abbaye): New variable.
parent
586b6d4d
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/games.scm
+64
-0
64 additions, 0 deletions
gnu/packages/games.scm
with
64 additions
and
0 deletions
gnu/packages/games.scm
+
64
−
0
View file @
3da5dca3
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 John Darrington <jmd@gnu.org>
;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -32,6 +33,7 @@ (define-module (gnu packages games)
#
:use-module
(
gnu
packages
xorg
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
sqlite
)
#
:use-module
(
gnu
packages
sdl
)
#
:use-module
(
guix
build-system
gnu
))
(
define-public
gnubg
...
...
@@ -94,3 +96,65 @@ (define-public gnubik
You may even apply photos to the faces instead of colors. The game is
scriptable with Guile."
)
(
license
gpl3+
)))
(
define-public
abbaye
(
package
(
name
"abbaye"
)
(
version
"1.13"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://abbaye-for-linux.googlecode.com/files/abbaye-for-linux-src-"
version
".tar.gz"
))
(
sha256
(
base32
"1wgvckgqa2084rbskxif58wbb83xbas8s1i8s7d57xbj08ryq8rk"
))))
(
build-system
gnu-build-system
)
(
arguments
'
(
#
:modules
((
ice-9
match
)
(
guix
build
gnu-build-system
)
(
guix
build
utils
))
#
:phases
(
alist-cons-after
'set-paths
'set-sdl-paths
(
lambda*
(
#
:key
inputs
outputs
(
search-paths
'
())
#
:allow-other-keys
)
(
define
input-directories
(
match
inputs
(((
_
.
dir
)
...
)
dir
)))
;; This package does not use pkg-config, so modify CPATH
;; variable to point to include/SDL for SDL header files.
(
set-path-environment-variable
"CPATH"
'
(
"include/SDL"
)
input-directories
))
(
alist-cons-after
'patch-source-shebangs
'patch-makefile
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
;; Replace /usr with package output directory.
(
for-each
(
lambda
(
file
)
(
substitute*
file
((
"/usr"
)
(
assoc-ref
outputs
"out"
))))
'
(
"makefile"
"src/pantallas.c"
"src/comun.h"
)))
(
alist-cons-before
'install
'make-install-dirs
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let
((
prefix
(
assoc-ref
outputs
"out"
)))
;; Create directories that the makefile assumes exist.
(
mkdir-p
(
string-append
prefix
"/bin"
))
(
mkdir-p
(
string-append
prefix
"/share/applications"
))))
;; No configure script.
(
alist-delete
'configure
%standard-phases
))))
#
:tests?
#f
))
;; No check target.
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"sdl"
,
sdl
)
(
"sdl-gfx"
,
sdl-gfx
)
(
"sdl-image"
,
sdl-image
)
(
"sdl-mixer"
,
sdl-mixer
)
(
"sdl-ttf"
,
sdl-ttf
)))
(
home-page
"http://code.google.com/p/abbaye-for-linux/"
)
(
synopsis
"GNU/Linux port of the indie game \"l'Abbaye des Morts\""
)
(
description
"L'Abbaye des Morts is a 2D platform game set in 13th century
France. The Cathars, who preach about good Christian beliefs, were being
expelled by the Catholic Church out of the Languedoc region in France. One of
them, called Jean Raymond, found an old church in which to hide, not knowing
that beneath its ruins lay buried an ancient evil."
)
(
license
gpl3+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment