Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
44298269
Commit
44298269
authored
9 years ago
by
Leo Famulari
Committed by
David Thompson
9 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add dialog.
* gnu/packages/python.scm (dialog): New variable.
parent
99fffa8a
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ncurses.scm
+25
-0
25 additions, 0 deletions
gnu/packages/ncurses.scm
with
25 additions
and
0 deletions
gnu/packages/ncurses.scm
+
25
−
0
View file @
44298269
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -110,3 +111,27 @@ (define lib.so
ncursesw library provides wide character support."
)
(
license
x11
)
(
home-page
"http://www.gnu.org/software/ncurses/"
))))
(
define-public
dialog
(
package
(
name
"dialog"
)
(
version
"1.2-20150920"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://invisible-mirror.net/archives/dialog/dialog-"
version
".tgz"
))
(
sha256
(
base32
"01ccd585c241nkj02n0zdbx8jqhylgcfpcmmshynh0c7fv2ixrn4"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:tests?
#f
))
; no test suite
(
inputs
`
((
"ncurses"
,
ncurses
)))
(
synopsis
"Curses widgets"
)
(
description
"Dialog is a script-interpreter which provides a set of
curses widgets, such as dialog boxes."
)
(
home-page
"http://invisible-island.net/dialog/dialog.html"
)
;; Includes the gpl3 file "config.sub" from Automake.
(
license
(
list
lgpl2
.
1
gpl3
))))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment