Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
476b583f
Unverified
Commit
476b583f
authored
8 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add sbcl-iterate.
* gnu/packages/lisp.scm (sbcl-iterate): New variable.
parent
d0eec99a
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/lisp.scm
+28
-0
28 additions, 0 deletions
gnu/packages/lisp.scm
with
28 additions
and
0 deletions
gnu/packages/lisp.scm
+
28
−
0
View file @
476b583f
...
...
@@ -1273,3 +1273,31 @@ (define-public sbcl-parse-number
else @code{parse-number} signals an error of type @code{invalid-number}."
)
(
license
license:bsd-3
)))
(
define-public
sbcl-iterate
(
package
(
name
"sbcl-iterate"
)
;; The latest official release (1.4.3) fails to build so we have to take
;; the current darcs tarball from quicklisp.
(
version
"20160825"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://beta.quicklisp.org/archive/iterate/"
"2016-08-25/iterate-"
version
"-darcs.tgz"
))
(
sha256
(
base32
"0kvz16gnxnkdz0fy1x8y5yr28nfm7i2qpvix7mgwccdpjmsb4pgm"
))))
(
build-system
asdf-build-system/sbcl
)
(
home-page
"https://common-lisp.net/project/iterate/"
)
(
synopsis
"Iteration construct for Common Lisp"
)
(
description
"@code{iterate} is an iteration construct for Common Lisp.
It is similar to the @code{CL:LOOP} macro, with these distinguishing marks:
@itemize
@item it is extensible,
@item it helps editors like Emacs indent iterate forms by having a more
lisp-like syntax, and
@item it isn't part of the ANSI standard for Common Lisp.
@end itemize\n"
)
(
license
license:expat
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment