Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
492ee988
Commit
492ee988
authored
9 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add Camlp4.
* gnu/packages/ocaml.scm (camlp4): New variable.
parent
dee2b3bd
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ocaml.scm
+42
-0
42 additions, 0 deletions
gnu/packages/ocaml.scm
with
42 additions
and
0 deletions
gnu/packages/ocaml.scm
+
42
−
0
View file @
492ee988
...
@@ -192,6 +192,48 @@ (define-public opam
...
@@ -192,6 +192,48 @@ (define-public opam
;; The 'LICENSE' file waives some requirements compared to LGPLv3.
;; The 'LICENSE' file waives some requirements compared to LGPLv3.
(
license
lgpl3
)))
(
license
lgpl3
)))
(
define-public
camlp4
(
package
(
name
"camlp4"
)
(
version
"4.02.0+1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/ocaml/camlp4/archive/"
version
".tar.gz"
))
(
sha256
(
base32
"0055f4jiz82rgn581xhq3mr4qgq2qgdxqppmp8i2x1xnsim4h9pn"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"ocaml"
,
ocaml
)
(
"which"
,
which
)))
(
inputs
`
((
"ocaml"
,
ocaml
)))
(
arguments
'
(
#
:tests?
#f
;no documented test target
#
:phases
(
modify-phases
%standard-phases
(
replace
'configure
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
;; This is a home-made 'configure' script.
(
let
((
out
(
assoc-ref
outputs
"out"
)))
(
zero?
(
system*
"./configure"
(
string-append
"--libdir="
out
"/lib"
)
(
string-append
"--bindir="
out
"/bin"
)
(
string-append
"--pkgdir="
out
)))))))))
(
home-page
"https://github.com/ocaml/camlp4"
)
(
synopsis
"Write parsers in OCaml"
)
(
description
"Camlp4 is a software system for writing extensible parsers for
programming languages. It provides a set of OCaml libraries that are used to
define grammars as well as loadable syntax extensions of such grammars.
Camlp4 stands for Caml Preprocessor and Pretty-Printer and one of its most
important applications is the definition of domain-specific extensions of the
syntax of OCaml."
)
;; This is LGPLv2 with an exception that allows packages statically-linked
;; against the library to be released under any terms.
(
license
lgpl2
.
0
)))
(
define-public
camlp5
(
define-public
camlp5
(
package
(
package
(
name
"camlp5"
)
(
name
"camlp5"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment