Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
4a827670
Commit
4a827670
authored
9 years ago
by
Andreas Enge
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add kwindowsystem.
* gnu/packages/kde-frameworks.scm (kwindowsystem): New variable.
parent
f272987a
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/kde-frameworks.scm
+41
-1
41 additions, 1 deletion
gnu/packages/kde-frameworks.scm
with
41 additions
and
1 deletion
gnu/packages/kde-frameworks.scm
+
41
−
1
View file @
4a827670
...
...
@@ -21,7 +21,10 @@ (define-module (gnu packages kde-frameworks)
#
:use-module
(
guix
download
)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
utils
))
#
:use-module
(
guix
utils
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
qt
)
#
:use-module
(
gnu
packages
xorg
))
(
define
kde-frameworks-version
"5.12.0"
)
...
...
@@ -48,3 +51,40 @@ (define-public extra-cmake-modules
modules provided by CMake to find common software. In addition, it provides
common build settings used in software produced by the KDE community."
)
(
license
license:bsd-3
)))
(
define-public
kwindowsystem
(
package
(
name
"kwindowsystem"
)
(
version
kde-frameworks-version
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://download.kde.org/stable/frameworks/"
(
version-major+minor
version
)
"/"
name
"-"
version
".tar.xz"
))
(
sha256
(
base32
"0fjxhf07r186cmp0mjvinrwxg4z90zlyvycqhy0n18fdp67szckl"
))))
(
build-system
cmake-build-system
)
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)
(
"xorg-server"
,
xorg-server
)))
; for the tests
(
inputs
`
((
"extra-cmake-modules"
,
extra-cmake-modules
)
(
"libxrender"
,
libxrender
)
(
"qt"
,
qt
)
(
"xcb-utils-keysyms"
,
xcb-util-keysyms
)))
(
arguments
`
(
#
:tests?
#f
))
; FIXME: The first seven tests fail with "Exception".
(
home-page
"https://community.kde.org/Frameworks"
)
(
synopsis
"KDE access to the windowing system"
)
(
description
"KWindowSystem provides information about and allows
interaction with the windowing system. It provides a high level API, which
is windowing system independent and has platform specific
implementations. This API is inspired by X11 and thus not all functionality
is available on all windowing systems.
In addition to the high level API, this framework also provides several
lower level classes for interaction with the X Windowing System."
)
;; Some source files mention lgpl2.0+, but the included license is
;; the lgpl2.1. Some source files are under non-copyleft licenses.
(
license
license:lgpl2
.
1
+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment