Skip to content
Snippets Groups Projects
Unverified Commit 4e869b18 authored by Simon South's avatar Simon South Committed by Tobias Geerinckx-Rice
Browse files

gnu: knot: Fix test failure on aarch64-linux.


* gnu/packages/dns.scm (knot)[source]: Apply patch from upstream that
helps ensure the "test_net_shortwrite" test suite can complete
regardless of platform or configuration.
* gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: default avatarTobias Geerinckx-Rice <me@tobias.gr>
parent 4756b9b1
No related branches found
No related tags found
No related merge requests found
......@@ -1198,6 +1198,7 @@ dist_patch_DATA = \
%D%/packages/patches/kpackage-allow-external-paths.patch \
%D%/packages/patches/kmplayer-aarch64.patch \
%D%/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch \
%D%/packages/patches/knot-test_net_shortwrite-ensure-connection.patch \
%D%/packages/patches/kobodeluxe-paths.patch \
%D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch \
%D%/packages/patches/kobodeluxe-const-charp-conversion.patch \
......
......@@ -816,6 +816,8 @@ (define-public knot
(file-name (git-file-name name version))
(sha256
(base32 "0fkvip7n5ihjfwnnivdc3jf44y8p85ifglvq7b0anxvj9cg1m78f"))
(patches
(search-patches "knot-test_net_shortwrite-ensure-connection.patch"))
(modules '((guix build utils)))
(snippet
'(begin
......
This patch duplicates upstream commit 4144d1e, which helps ensure the
"test_net_shortwrite" test suite can succeed across all platforms by
deepening the pending-connection queue of the server it creates from 0
to 1.
See the original report at
https://gitlab.nic.cz/knot/knot-dns/-/issues/693
--- a/tests/contrib/test_net_shortwrite.c
+++ b/tests/contrib/test_net_shortwrite.c
@@ -88,7 +88,7 @@ int main(int argc, char *argv[])
int server = net_bound_socket(SOCK_STREAM, &addr, 0);
ok(server >= 0, "server: bind socket");
- r = listen(server, 0);
+ r = listen(server, 1);
ok(r == 0, "server: start listening");
struct sockaddr *sa = (struct sockaddr *)&addr;
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment