Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
4f028c8f
Commit
4f028c8f
authored
12 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add Geiser.
* gnu/packages/emacs.scm (geiser): New variable.
parent
dc56970d
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/emacs.scm
+39
-1
39 additions, 1 deletion
gnu/packages/emacs.scm
with
39 additions
and
1 deletion
gnu/packages/emacs.scm
+
39
−
1
View file @
4f028c8f
...
@@ -25,7 +25,8 @@ (define-module (gnu packages emacs)
...
@@ -25,7 +25,8 @@ (define-module (gnu packages emacs)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
texinfo
)
#
:use-module
(
gnu
packages
texinfo
)
#
:use-module
(
gnu
packages
gnutls
)
#
:use-module
(
gnu
packages
gnutls
)
#
:use-module
(
gnu
packages
pkg-config
))
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
guile
))
(
define-public
emacs
(
define-public
emacs
(
package
(
package
...
@@ -91,3 +92,40 @@ (define-public emacs
...
@@ -91,3 +92,40 @@ (define-public emacs
extensions are distributed with GNU Emacs; others are available
extensions are distributed with GNU Emacs; others are available
separately."
)
separately."
)
(
license
gpl3+
)))
(
license
gpl3+
)))
;;;
;;; Emacs hacking.
;;;
(
define-public
geiser
(
package
(
name
"geiser"
)
(
version
"0.3"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://savannah/geiser/0.3/geiser-"
version
".tar.gz"
))
(
sha256
(
base32
"1yzx0k1y5dq0m9dr3zdrxd8li0pddzblzj1ngd0spvsvvzz6v13j"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"guile"
,
guile-2
.
0
)
(
"emacs"
,
emacs
)))
(
home-page
"http://nongnu.org/geiser/"
)
(
synopsis
"Collection of Emacs modes for Guile and Racket hacking"
)
(
description
"Geiser is a collection of Emacs major and minor modes that
conspire with one or more Scheme interpreters to keep the Lisp Machine
Spirit alive. It draws inspiration (and a bit more) from environments
such as Common Lisp’s Slime, Factor’s FUEL, Squeak or Emacs itself, and
does its best to make Scheme hacking inside Emacs (even more) fun.
Or, to be precise, what i consider fun. Geiser is thus my humble
contribution to the dynamic school of expression, and a reaction against
what i perceive as a derailment, in modern times, of standard Scheme
towards the static camp. Because i prefer growing and healing to poking
at corpses, the continuously running Scheme interpreter takes the center
of the stage in Geiser. A bundle of Elisp shims orchestrates the dialog
between the Scheme interpreter, Emacs and, ultimately, the schemer,
giving her access to live metadata."
)
(
license
bsd-3
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment