Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
4f7e152b
Commit
4f7e152b
authored
11 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add torsocks.
* gnu/packages/tor.scm (torsocks): New variable.
parent
842ded33
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/tor.scm
+24
-1
24 additions, 1 deletion
gnu/packages/tor.scm
with
24 additions
and
1 deletion
gnu/packages/tor.scm
+
24
−
1
View file @
4f7e152b
...
...
@@ -17,7 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(
define-module
(
gnu
packages
tor
)
#
:use-module
((
guix
licenses
)
#
:select
(
bsd-3
))
#
:use-module
((
guix
licenses
)
#
:select
(
bsd-3
gpl2+
))
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
gnu
)
...
...
@@ -41,6 +41,9 @@ (define-public tor
`
((
"zlib"
,
zlib
)
(
"openssl"
,
openssl
)
(
"libevent"
,
libevent
)))
;; TODO: Recommend `torsocks' since `torify' needs it.
(
home-page
"http://www.torproject.org/"
)
(
synopsis
"An anonymous network router to improve privacy on the Internet"
)
(
description
...
...
@@ -52,3 +55,23 @@ (define-public tor
web browsers, instant messaging clients, remote login, and other
applications based on the TCP protocol."
)
(
license
bsd-3
)))
(
define-public
torsocks
(
package
(
name
"torsocks"
)
(
version
"1.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://torsocks.googlecode.com/files/torsocks-"
version
".tar.gz"
))
(
sha256
(
base32
"1m0is5q24sf7jjlkl0icfkdc0m53nbkg0q72s57p48yp4hv7v9dy"
))))
(
build-system
gnu-build-system
)
(
home-page
"http://code.google.com/p/torsocks/"
)
(
synopsis
"Use socks-friendly applications with Tor"
)
(
description
"Torsocks allows you to use most socks-friendly applications in a safe
way with Tor. It ensures that DNS requests are handled safely and explicitly
rejects UDP traffic from the application you're using."
)
(
license
gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment