Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
51d3dcea
Commit
51d3dcea
authored
10 years ago
by
John Darrington
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add qrencode.
* gnu/packages/aidc.scm (qrencode): New variable.
parent
e55354b8
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/aidc.scm
+24
-0
24 additions, 0 deletions
gnu/packages/aidc.scm
with
24 additions
and
0 deletions
gnu/packages/aidc.scm
+
24
−
0
View file @
51d3dcea
...
@@ -22,6 +22,8 @@ (define-module (gnu packages aidc)
...
@@ -22,6 +22,8 @@ (define-module (gnu packages aidc)
#
:renamer
(
symbol-prefix-proc
'license:
))
#
:renamer
(
symbol-prefix-proc
'license:
))
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
libpng
)
#
:use-module
(
guix
build-system
gnu
))
#
:use-module
(
guix
build-system
gnu
))
...
@@ -43,3 +45,25 @@ (define-public barcode
...
@@ -43,3 +45,25 @@ (define-public barcode
formats."
)
formats."
)
(
license
license:gpl3+
)
(
license
license:gpl3+
)
(
home-page
"http://www.gnu.org/software/barcode/"
)))
(
home-page
"http://www.gnu.org/software/barcode/"
)))
(
define-public
qrencode
(
package
(
name
"qrencode"
)
(
version
"3.4.3"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://fukuchi.org/works/qrencode/qrencode-"
version
".tar.bz2"
))
(
sha256
(
base32
"163sb580p570p27imc6jhkfdw15kzp8vy1jq92nip1rwa63i9myz"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"libpng"
,
libpng
)))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
synopsis
"Encode data into a QR Code symbol"
)
(
description
"Libqrencode is a C library for encoding data in a QR Code
symbol, a kind of 2D symbology that can be scanned by handy terminals such as
a mobile phone with CCD. The capacity of QR Code is up to 7000 digits or 4000
characters, and is highly robust."
)
(
license
license:lgpl2
.
1
+
)
(
home-page
"http://fukuchi.org/works/qrencode"
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment