Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
53b9684e
Unverified
Commit
53b9684e
authored
8 years ago
by
Federico Beffa
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add chez-mit.
* gnu/packages/chez.scm (chez-mit): New variable.
parent
08fc0d68
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/chez.scm
+29
-1
29 additions, 1 deletion
gnu/packages/chez.scm
with
29 additions
and
1 deletion
gnu/packages/chez.scm
+
29
−
1
View file @
53b9684e
...
@@ -19,7 +19,7 @@
...
@@ -19,7 +19,7 @@
(
define-module
(
gnu
packages
chez
)
(
define-module
(
gnu
packages
chez
)
#
:use-module
(
gnu
packages
)
#
:use-module
(
gnu
packages
)
#
:use-module
((
guix
licenses
)
#
:use-module
((
guix
licenses
)
#
:select
(
gpl2+
lgpl2
.
0
+
lgpl2
.
1
+
asl2
.
0
bsd-3
expat
#
:select
(
gpl2+
gpl3+
lgpl2
.
0
+
lgpl2
.
1
+
asl2
.
0
bsd-3
expat
public-domain
))
public-domain
))
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
...
@@ -470,3 +470,31 @@ (define-public chez-fmt
...
@@ -470,3 +470,31 @@ (define-public chez-fmt
without resorting to capturing and manipulating intermediate
without resorting to capturing and manipulating intermediate
strings."
)
strings."
)
(
license
bsd-3
)))
(
license
bsd-3
)))
(
define-public
chez-mit
(
package
(
name
"chez-mit"
)
(
version
"0.1"
)
(
home-page
"https://github.com/fedeinthemix/chez-mit"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
home-page
"/archive/v"
version
".tar.gz"
))
(
sha256
(
base32
"1p11q061znwxzxrxg3vw4dbsnpv1dav12hjhnkrjnzyyjvvdm2kn"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"chez-srfi"
,
chez-srfi
)))
; for tests
(
native-inputs
`
((
"chez-scheme"
,
chez-scheme
)))
(
arguments
`
(
#
:make-flags
,
(
chez-make-flags
name
version
)
#
:test-target
"test"
#
:phases
(
modify-phases
%standard-phases
(
replace
'configure
,
chez-configure
))))
(
synopsis
"MIT/GNU Scheme compatibility library for Chez Scheme"
)
(
description
"This package provides a set of MIT/GNU Scheme compatibility
libraries for Chez Scheme. The main goal was to provide the functionality
required to port the program 'Scmutils' to Chez Scheme."
)
(
license
gpl3+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment