Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
5854f685
Commit
5854f685
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add GRIT.
* gnu/packages/bioinformatics.scm (grit): New variable.
parent
ee3e157d
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/bioinformatics.scm
+51
-0
51 additions, 0 deletions
gnu/packages/bioinformatics.scm
with
51 additions
and
0 deletions
gnu/packages/bioinformatics.scm
+
51
−
0
View file @
5854f685
...
@@ -511,6 +511,57 @@ (define-public flexbar
...
@@ -511,6 +511,57 @@ (define-public flexbar
Illumina, Roche 454, and the SOLiD platform."
)
Illumina, Roche 454, and the SOLiD platform."
)
(
license
license:gpl3
)))
(
license
license:gpl3
)))
(
define-public
grit
(
package
(
name
"grit"
)
(
version
"2.0.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/nboley/grit/archive/"
version
".tar.gz"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"157in84dj70wimbind3x7sy1whs3h57qfgcnj2s6lrd38fbrb7mj"
))))
(
build-system
python-build-system
)
(
arguments
`
(
#
:python
,
python-2
#
:phases
(
alist-cons-after
'unpack
'generate-from-cython-sources
(
lambda*
(
#
:key
inputs
outputs
#
:allow-other-keys
)
;; Delete these C files to force fresh generation from pyx sources.
(
delete-file
"grit/sparsify_support_fns.c"
)
(
delete-file
"grit/call_peaks_support_fns.c"
)
(
substitute*
"setup.py"
((
"Cython.Setup"
)
"Cython.Build"
)
;; Add numpy include path to fix compilation
((
"pyx\", \\]"
)
(
string-append
"pyx\", ], include_dirs = ['"
(
assoc-ref
inputs
"python-numpy"
)
"/lib/python2.7/site-packages/numpy/core/include/"
"']"
)))
#t
)
%standard-phases
)))
(
inputs
`
((
"python-scipy"
,
python2-scipy
)
(
"python-numpy"
,
python2-numpy
)
(
"python-pysam"
,
python2-pysam
)
(
"python-networkx"
,
python2-networkx
)))
(
native-inputs
`
((
"python-cython"
,
python2-cython
)
(
"python-setuptools"
,
python2-setuptools
)))
(
home-page
"http://grit-bio.org"
)
(
synopsis
"Tool for integrative analysis of RNA-seq type assays"
)
(
description
"GRIT is designed to use RNA-seq, TES, and TSS data to build and quantify
full length transcript models. When none of these data sources are available,
GRIT can be run by providing a candidate set of TES or TSS sites. In
addition, GRIT can merge in reference junctions and gene boundaries. GRIT can
also be run in quantification mode, where it uses a provided GTF file and just
estimates transcript expression."
)
(
license
license:gpl3+
)))
(
define-public
hisat
(
define-public
hisat
(
package
(
package
(
name
"hisat"
)
(
name
"hisat"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment