Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
59ef2030
Commit
59ef2030
authored
9 years ago
by
Mathieu Lirzin
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add cvs-fast-export.
* gnu/packages/version-control.scm (cvs-fast-export): New variable.
parent
610075f7
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/version-control.scm
+42
-0
42 additions, 0 deletions
gnu/packages/version-control.scm
with
42 additions
and
0 deletions
gnu/packages/version-control.scm
+
42
−
0
View file @
59ef2030
...
@@ -3,6 +3,7 @@
...
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;;
;;;
...
@@ -34,10 +35,12 @@ (define-module (gnu packages version-control)
...
@@ -34,10 +35,12 @@ (define-module (gnu packages version-control)
#
:use-module
(
guix
build-system
trivial
)
#
:use-module
(
guix
build-system
trivial
)
#
:use-module
(
guix
build
utils
)
#
:use-module
(
guix
build
utils
)
#
:use-module
(
gnu
packages
apr
)
#
:use-module
(
gnu
packages
apr
)
#
:use-module
(
gnu
packages
asciidoc
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
base
)
#
:use-module
(
gnu
packages
bison
)
#
:use-module
(
gnu
packages
bison
)
#
:use-module
(
gnu
packages
cook
)
#
:use-module
(
gnu
packages
cook
)
#
:use-module
(
gnu
packages
curl
)
#
:use-module
(
gnu
packages
curl
)
#
:use-module
(
gnu
packages
docbook
)
#
:use-module
(
gnu
packages
ed
)
#
:use-module
(
gnu
packages
ed
)
#
:use-module
(
gnu
packages
file
)
#
:use-module
(
gnu
packages
file
)
#
:use-module
(
gnu
packages
flex
)
#
:use-module
(
gnu
packages
flex
)
...
@@ -683,6 +686,45 @@ (define-public cvs
...
@@ -683,6 +686,45 @@ (define-public cvs
RCS, PRCS, and Aegis packages."
)
RCS, PRCS, and Aegis packages."
)
(
license
gpl1+
)))
(
license
gpl1+
)))
(
define-public
cvs-fast-export
(
package
(
name
"cvs-fast-export"
)
(
version
"1.33"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://www.catb.org/~esr/"
name
"/"
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"1c3s4nacbwlaaccx1fr7hf72kxxrzy49y2rdz5hhqbk8r29vm8w1"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
(
delete
'configure
))
#
:make-flags
(
list
"CC=gcc"
(
string-append
"prefix?="
(
assoc-ref
%outputs
"out"
)))))
(
inputs
`
((
"git"
,
git
)))
(
native-inputs
`
((
"asciidoc"
,
asciidoc
)
(
"docbook-xml"
,
docbook-xml
)
(
"docbook-xsl"
,
docbook-xsl
)
(
"xmllint"
,
libxml2
)
(
"xsltproc"
,
libxslt
)
;; These are needed for the tests.
(
"cvs"
,
cvs
)
(
"python"
,
python-2
)
(
"rcs"
,
rcs
)))
(
home-page
"http://www.catb.org/esr/cvs-fast-export/"
)
(
synopsis
"Export an RCS or CVS history as a fast-import stream"
)
(
description
"This program analyzes a collection of RCS files in a CVS
repository (or outside of one) and, when possible, emits an equivalent history
in the form of a fast-import stream. Not all possible histories can be
rendered this way; the program tries to emit useful warnings when it can't.
The program can also produce a visualization of the resulting commit directed
acyclic graph (DAG) in the input format of @uref{http://www.graphviz.org,
Graphviz}. The package also includes @command{cvssync}, a tool for mirroring
masters from remote CVS hosts."
)
(
license
gpl2+
)))
(
define-public
vc-dwim
(
define-public
vc-dwim
(
package
(
package
(
name
"vc-dwim"
)
(
name
"vc-dwim"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment