Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
61c30e9d
Commit
61c30e9d
authored
9 years ago
by
Leo Famulari
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add khard.
* gnu/packages/mail.scm (khard): New variable.
parent
eed1a61f
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/mail.scm
+44
-3
44 additions, 3 deletions
gnu/packages/mail.scm
with
44 additions
and
3 deletions
gnu/packages/mail.scm
+
44
−
3
View file @
61c30e9d
...
@@ -71,8 +71,8 @@ (define-module (gnu packages mail)
...
@@ -71,8 +71,8 @@ (define-module (gnu packages mail)
#
:use-module
(
gnu
packages
xml
)
#
:use-module
(
gnu
packages
xml
)
#
:use-module
(
gnu
packages
xorg
)
#
:use-module
(
gnu
packages
xorg
)
#
:use-module
((
guix
licenses
)
#
:use-module
((
guix
licenses
)
#
:select
(
gpl2
gpl2+
gpl3+
lgpl2
.
1
lgpl2
.
1
+
lgpl3+
non-copyleft
#
:select
(
gpl2
gpl2+
gpl3
gpl3+
lgpl2
.
1
lgpl2
.
1
+
lgpl3+
(
expat
.
license:expat
)))
non-copyleft
(
expat
.
license:expat
)))
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
git-download
)
#
:use-module
(
guix
git-download
)
...
@@ -1150,5 +1150,46 @@ (define-public procmail
...
@@ -1150,5 +1150,46 @@ (define-public procmail
;; nonfree Artistic License 1.0
;; nonfree Artistic License 1.0
;; as alternative to the GPL2+.
;; as alternative to the GPL2+.
;; This option is not listed here.
;; This option is not listed here.
;;; mail.scm ends here
(
define-public
khard
(
package
(
name
"khard"
)
(
version
"0.8.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
pypi-uri
name
version
))
(
sha256
(
base32
"098gs94qmnspdfn6ar8lycx7dbsz9bcff90aps0cmn47mw7llch0"
))))
(
build-system
python-build-system
)
(
arguments
`
(
#
:python
,
python-2
; only python-2 is supported.
#
:phases
(
modify-phases
%standard-phases
(
add-before
'build
'disable-egg-compression
;; Do not compress the egg.
(
lambda
_
(
let
((
port
(
open-file
"setup.cfg"
"a"
)))
(
display
"\n[easy_install]\nzip_ok = 0\n"
port
)
(
close-port
port
)
#t
)))
(
add-after
'install
'install-doc
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let*
((
out
(
assoc-ref
outputs
"out"
))
(
doc
(
string-append
out
"/share/doc/khard"
)))
(
copy-recursively
"misc/khard"
doc
)))))))
(
native-inputs
`
((
"python2-setuptools"
,
python2-setuptools
)))
(
propagated-inputs
`
((
"python2-vobject"
,
python2-vobject
)
(
"python2-pyyaml"
,
python2-pyyaml
)
(
"python2-atomicwrites"
,
python2-atomicwrites
)
(
"python2-configobj"
,
python2-configobj
)))
(
synopsis
"Console address book using CardDAV"
)
(
description
"Khard is an address book for the console. It creates, reads,
modifies and removes CardDAV address book entries at your local machine. For
synchronizing with a remote address book, @command{vdirsyncer} is recommended.
Khard can also be used from within the email client @command{mutt}."
)
(
home-page
"https://github.com/scheibler/khard"
)
(
license
gpl3+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment