Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
65dccb3a
Unverified
Commit
65dccb3a
authored
8 years ago
by
Efraim Flashner
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add vifm.
* gnu/packages/vim.scm (vifm): New variable.
parent
0b34b586
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/vim.scm
+60
-0
60 additions, 0 deletions
gnu/packages/vim.scm
with
60 additions
and
0 deletions
gnu/packages/vim.scm
+
60
−
0
View file @
65dccb3a
...
...
@@ -31,6 +31,7 @@ (define-module (gnu packages vim)
#
:use-module
(
gnu
packages
gawk
)
#
:use-module
(
gnu
packages
gettext
)
#
:use-module
(
gnu
packages
glib
)
#
:use-module
(
gnu
packages
groff
)
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
linux
)
...
...
@@ -147,3 +148,62 @@ (define-public vim-full
(
"ruby"
,
ruby
)
(
"tcl"
,
tcl
)
,@
(
package-inputs
vim
)))))
(
define-public
vifm
(
package
(
name
"vifm"
)
(
version
"0.8.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/vifm/vifm/vifm-"
version
".tar.bz2"
))
(
sha256
(
base32
"07r15kq7kjl3a41sd11ncpsii866xxps4f90zh3lv8jqcrv6silb"
))))
(
build-system
gnu-build-system
)
(
arguments
'
(
#
:phases
(
modify-phases
%standard-phases
(
add-after
'patch-source-shebangs
'patch-test-shebangs
(
lambda
_
(
substitute*
(
find-files
"tests"
"\\.c$"
)
((
"/bin/sh"
)
(
which
"sh"
)))
#t
)))))
(
native-inputs
`
((
"groff"
,
groff
)
; for the documentation
(
"perl"
,
perl
)))
(
inputs
`
((
"libx11"
,
libx11
)
(
"ncurses"
,
ncurses
)))
(
home-page
"http://vifm.info/"
)
(
synopsis
"Flexible vi-like file manager using ncurses"
)
(
description
"Vifm is a file manager providing a @command{vi}-like usage
experience. It has similar keybindings and modes (e.g. normal, command line,
visual). The interface uses ncurses, thus vifm can be used in text-only
environments. It supports a wide range of features, some of which are known
from the @command{vi}-editor:
@enumerate
@item utf8 support
@item user mappings (almost like in @code{vi})
@item ranges in command
@item line commands
@item user defined commands (with support for ranges)
@item registers
@item operation undoing/redoing
@item fuse file systems support
@item trash
@item multiple files renaming
@item support of filename modifiers
@item colorschemes support
@item file name color according to file type
@item path specific colorscheme customization
@item bookmarks
@item operation backgrounding
@item customizable file viewers
@item handy @code{less}-like preview mode
@item filtering out and searching for files using regular expressions
@item one or two panes view
@end enumerate
With the package comes a plugin to use vifm as a vim file selector."
)
(
license
license:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment