Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
66e20863
Commit
66e20863
authored
9 years ago
by
David Thompson
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add ruby-git.
* gnu/packages/ruby.scm (ruby-git): New variable.
parent
0808e361
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ruby.scm
+50
-0
50 additions, 0 deletions
gnu/packages/ruby.scm
with
50 additions
and
0 deletions
gnu/packages/ruby.scm
+
50
−
0
View file @
66e20863
...
@@ -28,6 +28,7 @@ (define-module (gnu packages ruby)
...
@@ -28,6 +28,7 @@ (define-module (gnu packages ruby)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
libffi
)
#
:use-module
(
gnu
packages
libffi
)
#
:use-module
(
gnu
packages
gdbm
)
#
:use-module
(
gnu
packages
gdbm
)
#
:use-module
(
gnu
packages
version-control
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
git-download
)
#
:use-module
(
guix
git-download
)
...
@@ -570,3 +571,52 @@ (define-public ruby-daemons
...
@@ -570,3 +571,52 @@ (define-public ruby-daemons
run as a daemon and to be controlled by simple start/stop/restart commands."
)
run as a daemon and to be controlled by simple start/stop/restart commands."
)
(
home-page
"https://github.com/thuehlinger/daemons"
)
(
home-page
"https://github.com/thuehlinger/daemons"
)
(
license
license:expat
)))
(
license
license:expat
)))
(
define-public
ruby-git
(
package
(
name
"ruby-git"
)
(
version
"1.2.9.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/schacon/ruby-git/archive/v"
version
".tar.gz"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"08zg20zc7f7yy34ix2qdd8jbiz7xhjc8alk370869sq3h75hs9jc"
))))
(
build-system
ruby-build-system
)
(
arguments
'
(
#
:phases
(
modify-phases
%standard-phases
(
add-before
'build
'patch-git-binary
(
lambda*
(
#
:key
inputs
#
:allow-other-keys
)
;; Make the default git binary an absolute path to the
;; store.
(
let
((
git
(
string-append
(
assoc-ref
inputs
"git"
)
"/bin/git"
)))
(
substitute*
'
(
"lib/git/config.rb"
)
((
"'git'"
)
(
string-append
"'"
git
"'"
)))
;; Fix a test that expects the binary to be simply
;; 'git'.
(
substitute*
'
(
"tests/units/test_logger.rb"
)
((
"def test_logger"
)
(
string-append
"def test_logger\n"
"Git::Base.config.binary_path = 'git'"
)))
#t
)))
(
add-before
'check
'create-fake-home
(
lambda
_
;; The test suite runs 'git config --global' commands,
;; so a fake home directory is needed for them to
;; succeed.
(
let
((
fake-home
(
string-append
(
getcwd
)
"/fake-home"
)))
(
mkdir
fake-home
)
(
setenv
"HOME"
fake-home
)))))))
(
inputs
`
((
"git"
,
git
)))
(
synopsis
"Ruby wrappers for Git"
)
(
description
"Ruby/Git is a Ruby library that can be used to create, read
and manipulate Git repositories by wrapping system calls to the git binary."
)
(
home-page
"https://github.com/schacon/ruby-git"
)
(
license
license:expat
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment