Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
66fb2d23
Commit
66fb2d23
authored
11 years ago
by
Ludovic Courtès
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add pavucontrol.
* gnu/packages/pulseaudio.scm (pavucontrol): New variable.
parent
ef0cf53e
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/pulseaudio.scm
+30
-0
30 additions, 0 deletions
gnu/packages/pulseaudio.scm
with
30 additions
and
0 deletions
gnu/packages/pulseaudio.scm
+
30
−
0
View file @
66fb2d23
...
...
@@ -27,6 +27,8 @@ (define-module (gnu packages pulseaudio)
#
:use-module
(
gnu
packages
pkg-config
)
#
:use-module
(
gnu
packages
avahi
)
#
:use-module
(
gnu
packages
glib
)
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
libcanberra
)
#
:use-module
(
gnu
packages
algebra
)
#
:use-module
((
gnu
packages
autotools
)
#
:select
(
libtool
))
#
:use-module
(
gnu
packages
gdbm
)
...
...
@@ -185,3 +187,31 @@ (define pulseaudio
;; FFTW, etc.) are GPL'd, so the result is effectively GPLv2+. See
;; 'LICENSE' for details.
(
license
l:gpl2+
)))
(
define-public
pavucontrol
(
package
(
name
"pavucontrol"
)
(
version
"2.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://freedesktop.org/software/pulseaudio/pavucontrol/pavucontrol-"
version
".tar.xz"
))
(
sha256
(
base32
"02s775m1531sshwlbvfddk3pz8zjmwkv1sgzggn386ja3gc9vwi2"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"intltool"
,
intltool
)
(
"libcanberra"
,
libcanberra
)
(
"gtkmm"
,
gtkmm
)
(
"pulseaudio"
,
pulseaudio
)
(
"pkg-config"
,
pkg-config
)))
(
home-page
"http://freedesktop.org/software/pulseaudio/pavucontrol/"
)
(
synopsis
"PulseAudio volume control"
)
(
description
"PulseAudio Volume Control (pavucontrol) provides a GTK+
graphical user interface to connect to a PulseAudio server and
easily control the volume of all clients, sinks, etc."
)
(
license
l:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment