Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
67fa7a27
Commit
67fa7a27
authored
10 years ago
by
Christine Lemmer-Webber
Committed by
David Thompson
10 years ago
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add extremetuxracer.
* gnu/packages/games.scm (extremetuxracer): New variable.
parent
85a02905
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/games.scm
+57
-0
57 additions, 0 deletions
gnu/packages/games.scm
with
57 additions
and
0 deletions
gnu/packages/games.scm
+
57
−
0
View file @
67fa7a27
...
...
@@ -9,6 +9,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
...
...
@@ -42,6 +43,7 @@ (define-module (gnu packages games)
#
:use-module
(
gnu
packages
gtk
)
#
:use-module
(
gnu
packages
guile
)
#
:use-module
(
gnu
packages
libcanberra
)
#
:use-module
(
gnu
packages
libunwind
)
#
:use-module
(
gnu
packages
image
)
#
:use-module
(
gnu
packages
ncurses
)
#
:use-module
(
gnu
packages
python
)
...
...
@@ -65,6 +67,7 @@ (define-module (gnu packages games)
#
:use-module
(
gnu
packages
lua
)
#
:use-module
(
gnu
packages
video
)
#
:use-module
(
gnu
packages
xml
)
#
:use-module
(
gnu
packages
tcl
)
#
:use-module
(
guix
build-system
trivial
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
cmake
)
...
...
@@ -822,3 +825,57 @@ (define-public gnugo
Modem Protocol)."
)
(
home-page
"http://www.gnu.org/software/gnugo/"
)
(
license
license:gpl3+
)))
(
define-public
extremetuxracer
(
package
(
name
"extremetuxracer"
)
(
version
"0.6.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://downloads.sourceforge.net/project/extremetuxracer/releases/"
version
"/etr-"
version
".tar.xz"
))
(
sha256
(
base32
"0fl9pwkywqnsmgr6plfj9zb05xrdnl5xb2hcmbjk7ap9l4cjfca4"
))))
(
build-system
gnu-build-system
)
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
inputs
`
((
"freetype"
,
freetype
)
(
"mesa"
,
mesa
)
(
"glu"
,
glu
)
(
"libice"
,
libice
)
(
"libpng"
,
libpng
)
(
"sdl"
,
sdl
)
(
"sdl-mixer"
,
sdl-mixer
)
(
"sdl-image"
,
sdl-image
)
(
"libsm"
,
libsm
)
(
"libunwind"
,
libunwind
)
(
"libx11"
,
libx11
)
(
"libxext"
,
libxext
)
(
"libxi"
,
libxi
)
(
"libxmu"
,
libxmu
)
(
"libxt"
,
libxt
)
(
"tcl"
,
tcl
)
(
"zlib"
,
zlib
)))
(
arguments
'
(
#
:phases
(
modify-phases
%standard-phases
(
add-after
'configure
'patch-makefile
(
lambda
_
(
substitute*
"Makefile"
((
"CXXFLAGS ="
)
"CXXFLAGS = ${CFLAGS}"
)))))))
(
synopsis
"High speed arctic racing game based on Tux Racer"
)
;; Snarfed straight from Debian
(
description
"Extreme Tux Racer, or etracer as it is called for short, is
a simple OpenGL racing game featuring Tux, the Linux mascot. The goal of the
game is to slide down a snow- and ice-covered mountain as quickly as possible,
avoiding the trees and rocks that will slow you down.
Collect herrings and other goodies while sliding down the hill, but avoid fish
bones.
This game is based on the GPL version of the famous game TuxRacer."
)
(
home-page
"http://sourceforge.net/projects/extremetuxracer/"
)
(
license
license:gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment