Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
69159125
Commit
69159125
authored
9 years ago
by
Mark H Weaver
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add mdadm.
* gnu/packages/linux.scm (mdadm): New variable.
parent
46a11302
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/linux.scm
+42
-0
42 additions, 0 deletions
gnu/packages/linux.scm
with
42 additions
and
0 deletions
gnu/packages/linux.scm
+
42
−
0
View file @
69159125
...
...
@@ -2071,3 +2071,45 @@ (define-public libiec61883
"The libiec61883 library provides a higher level API for streaming DV,
MPEG-2 and audio over Linux IEEE 1394."
)
(
license
lgpl2
.
1
+
)))
(
define-public
mdadm
(
package
(
name
"mdadm"
)
(
version
"3.3.2"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://kernel.org/linux/utils/raid/mdadm/mdadm-"
version
".tar.xz"
))
(
sha256
(
base32
"132vdvh3myjgcjn6i9w90ck16ddjxjcszklzkyvr4f5ifqd7wfhg"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"udev"
,
eudev
)))
(
arguments
`
(
#
:make-flags
(
let
((
out
(
assoc-ref
%outputs
"out"
)))
(
list
"INSTALL=install"
"CHECK_RUN_DIR=0"
;; TODO: tell it where to find 'sendmail'
;; (string-append "MAILCMD=" <???> "/sbin/sendmail")
(
string-append
"BINDIR="
out
"/sbin"
)
(
string-append
"MANDIR="
out
"/share/man"
)
(
string-append
"UDEVDIR="
out
"/lib/udev"
)))
#
:phases
(
alist-cons-before
'build
'patch-program-paths
(
lambda*
(
#
:key
inputs
#
:allow-other-keys
)
(
let
((
coreutils
(
assoc-ref
inputs
"coreutils"
)))
(
substitute*
"udev-md-raid-arrays.rules"
((
"/usr/bin/(readlink|basename)"
all
program
)
(
string-append
coreutils
"/bin/"
program
)))))
(
alist-delete
'configure
%standard-phases
))
;;tests must be done as root
#
:tests?
#f
))
(
home-page
"http://neil.brown.name/blog/mdadm"
)
(
synopsis
"Tool for managing Linux Software RAID arrays"
)
(
description
"mdadm is a tool for managing Linux Software RAID arrays. It can create,
assemble, report on, and monitor arrays. It can also move spares between raid
arrays when needed."
)
(
license
gpl2+
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment