Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
6ce212b8
Commit
6ce212b8
authored
9 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add pugixml.
* gnu/packages/xml.scm (pugixml): New variable.
parent
ccb8da26
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/xml.scm
+37
-0
37 additions, 0 deletions
gnu/packages/xml.scm
with
37 additions
and
0 deletions
gnu/packages/xml.scm
+
37
−
0
View file @
6ce212b8
...
@@ -2,6 +2,7 @@
...
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;;
;;; This file is part of GNU Guix.
;;; This file is part of GNU Guix.
;;;
;;;
...
@@ -30,6 +31,7 @@ (define-module (gnu packages xml)
...
@@ -30,6 +31,7 @@ (define-module (gnu packages xml)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
cmake
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
perl
)
#
:use-module
(
guix
build-system
perl
)
#
:use-module
(
gnu
packages
linux
))
#
:use-module
(
gnu
packages
linux
))
...
@@ -358,6 +360,41 @@ (define-public perl-xml-dom
...
@@ -358,6 +360,41 @@ (define-public perl-xml-dom
that conforms to the API of the Document Object Model."
)
that conforms to the API of the Document Object Model."
)
(
home-page
"http://search.cpan.org/~tjmather/XML-DOM-1.44/lib/XML/DOM.pm"
)))
(
home-page
"http://search.cpan.org/~tjmather/XML-DOM-1.44/lib/XML/DOM.pm"
)))
(
define-public
pugixml
(
package
(
name
"pugixml"
)
(
version
"1.6"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://github.com/zeux/pugixml/archive/v"
version
".tar.gz"
))
(
file-name
(
string-append
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"0czbcv9aqf2rw3s9cljz2wb1f4zbhd07wnj7ykklklccl0ipfnwi"
))))
(
build-system
cmake-build-system
)
(
arguments
`
(
#
:tests?
#f
#
:out-of-source?
#f
#
:phases
(
modify-phases
%standard-phases
(
add-before
'configure
'chdir
(
lambda
_
(
chdir
"scripts"
)
#t
)))))
(
home-page
"http://pugixml.org"
)
(
synopsis
"Light-weight, simple and fast XML parser for C++ with XPath support"
)
(
description
"pugixml is a C++ XML processing library, which consists of a DOM-like
interface with rich traversal/modification capabilities, a fast XML parser
which constructs the DOM tree from an XML file/buffer, and an XPath 1.0
implementation for complex data-driven tree queries. Full Unicode support is
also available, with Unicode interface variants and conversions between
different Unicode encodings which happen automatically during
parsing/saving."
)
(
license
license:expat
)))
(
define-public
xmlto
(
define-public
xmlto
(
package
(
package
(
name
"xmlto"
)
(
name
"xmlto"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment