Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
6e6b5344
Commit
6e6b5344
authored
9 years ago
by
Mathieu Lirzin
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add menu-cache.
* gnu/packages/lxde.scm (menu-cache): New variable.
parent
83365461
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/lxde.scm
+24
-1
24 additions, 1 deletion
gnu/packages/lxde.scm
with
24 additions
and
1 deletion
gnu/packages/lxde.scm
+
24
−
1
View file @
6e6b5344
...
@@ -24,7 +24,8 @@ (define-module (gnu packages lxde)
...
@@ -24,7 +24,8 @@ (define-module (gnu packages lxde)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
(
guix
packages
))
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
utils
))
(
define-public
libfm-extra
(
define-public
libfm-extra
(
package
(
package
...
@@ -72,4 +73,26 @@ (define-public lxappearance
...
@@ -72,4 +73,26 @@ (define-public lxappearance
(
home-page
"http://lxde.org"
)
(
home-page
"http://lxde.org"
)
(
license
license:gpl2+
)))
(
license
license:gpl2+
)))
(
define-public
menu-cache
(
package
(
name
"menu-cache"
)
(
version
"1.0.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/project/lxde/"
name
"/"
(
version-major+minor
version
)
"/"
name
"-"
version
".tar.xz"
))
(
sha256
(
base32
"1bws84fiwk3anp30hcr0lw1xw5cgp44x5ik2yv2ijcgxpcvz8zgz"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"glib"
,
glib
)
(
"libfm"
,
libfm-extra
)))
(
native-inputs
`
((
"pkg-config"
,
pkg-config
)))
(
synopsis
"LXDE implementation of the freedesktop menu's cache"
)
(
description
"Menu-cache is a library creating and utilizing caches to
speed up the access to freedesktop.org defined application menus."
)
(
home-page
"http://lxde.org"
)
(
license
license:lgpl2
.
1
+
)))
;;; lxde.scm ends here
;;; lxde.scm ends here
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment