Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
700ff222
Commit
700ff222
authored
9 years ago
by
Eric Bavier
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add p4est.
* gnu/packages/maths.scm (p4est, p4est-openmpi): New variables.
parent
e1ff597a
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/maths.scm
+46
-0
46 additions, 0 deletions
gnu/packages/maths.scm
with
46 additions
and
0 deletions
gnu/packages/maths.scm
+
46
−
0
View file @
700ff222
...
...
@@ -927,6 +927,52 @@ (define-public pt-scotch
(
lambda
_
(
zero?
(
system*
"make"
"ptcheck"
))))))))
(
synopsis
"Programs and libraries for graph algorithms (with MPI)"
)))
(
define-public
p4est
(
package
(
name
"p4est"
)
(
version
"1.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"http://p4est.github.io/release/p4est-"
version
".tar.gz"
))
(
sha256
(
base32
"0faina2h5qsx3m2izbzaj9bbakma1krbbjmq43wrp1hcbyijflqb"
))))
(
build-system
gnu-build-system
)
(
inputs
`
((
"fortran"
,
gfortran
)
(
"blas"
,
openblas
)
(
"lapack"
,
lapack
)
(
"zlib"
,
zlib
)))
(
arguments
`
(
#
:configure-flags
`
(
,
(
string-append
"BLAS_LIBS=-L"
(
assoc-ref
%build-inputs
"blas"
)
" -lopenblas"
)
,
(
string-append
"LAPACK_LIBS=-L"
(
assoc-ref
%build-inputs
"lapack"
)
" -llapack"
))))
(
home-page
"http://www.p4est.org"
)
(
synopsis
"Adaptive mesh refinement on forests of octrees"
)
(
description
"The p4est software library enables the dynamic management of a
collection of adaptive octrees, conveniently called a forest of octrees.
p4est is designed to work in parallel and scales to hundreds of thousands of
processor cores."
)
(
license
license:gpl2+
)))
(
define-public
p4est-openmpi
(
package
(
inherit
p4est
)
(
name
"p4est-openmpi"
)
(
inputs
`
((
"mpi"
,
openmpi
)
,@
(
package-inputs
p4est
)))
(
arguments
(
substitute-keyword-arguments
(
package-arguments
p4est
)
((
#
:configure-flags
cf
)
``
(
"--enable-mpi"
,@,
cf
))))
(
synopsis
"Parallel adaptive mesh refinement on forests of octrees"
)))
(
define-public
gsegrafix
(
package
(
name
"gsegrafix"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment