Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
7119cca8
Commit
7119cca8
authored
9 years ago
by
Mathieu Lirzin
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add artanis.
* gnu/packages/guile.scm (artanis): New variable.
parent
2936e48f
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/guile.scm
+51
-0
51 additions, 0 deletions
gnu/packages/guile.scm
with
51 additions
and
0 deletions
gnu/packages/guile.scm
+
51
−
0
View file @
7119cca8
...
...
@@ -29,6 +29,7 @@ (define-module (gnu packages guile)
#
:use-module
(
gnu
packages
autotools
)
#
:use-module
(
gnu
packages
flex
)
#
:use-module
(
gnu
packages
libunistring
)
#
:use-module
(
gnu
packages
linux
)
#
:use-module
(
gnu
packages
m4
)
#
:use-module
(
gnu
packages
multiprecision
)
#
:use-module
(
gnu
packages
pkg-config
)
...
...
@@ -242,6 +243,56 @@ (define-public guile-for-guile-emacs
;;; Extensions.
;;;
(
define-public
artanis
(
package
(
name
"artanis"
)
(
version
"0.1.0"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"ftp://alpha.gnu.org/gnu/artanis/artanis-"
version
".tar.gz"
))
(
sha256
(
base32
"1mc2zy6n9wnn4hzi3zp3jd6b5rlr0lv7fvh800xf4fyrxg0zia4g"
))))
(
build-system
gnu-build-system
)
;; TODO: Add guile-dbi and guile-dbd optional dependencies.
(
inputs
`
((
"guile"
,
guile-2
.
0
)))
(
native-inputs
`
((
"bash"
,
bash
)
;for the `source' builtin
(
"pkgconfig"
,
pkg-config
)
(
"util-linux"
,
util-linux
)))
;for the `script' command
(
arguments
'
(
#
:make-flags
;; TODO: The documentation must be built with the `docs' target.
(
let*
((
out
(
assoc-ref
%outputs
"out"
))
(
dir
(
string-append
out
"/share/guile/site/2.0"
)))
;; Don't use (%site-dir) for site paths.
(
list
(
string-append
"MOD_PATH="
dir
)
(
string-append
"MOD_COMPILED_PATH="
dir
)))
#
:test-target
"test"
#
:phases
(
modify-phases
%standard-phases
(
add-before
'install
'substitute-root-dir
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let
((
out
(
assoc-ref
outputs
"out"
)))
(
substitute*
"Makefile"
;ignore the execution of bash.bashrc
((
" /etc/bash.bashrc"
)
" /dev/null"
))
(
substitute*
"Makefile"
;set the root of config files to OUT
((
" /etc"
)
(
string-append
" "
out
"/etc"
)))
(
mkdir-p
(
string-append
out
"/bin"
))
;for the `art' executable
#t
))))))
(
synopsis
"Web application framework written in Guile"
)
(
description
"GNU Artanis is a web application framework written in Guile
Scheme. A web application framework (WAF) is a software framework that is
designed to support the development of dynamic websites, web applications, web
services and web resources. The framework aims to alleviate the overhead
associated with common activities performed in web development. Artanis
provides several tools for web development: database access, templating
frameworks, session management, URL-remapping for RESTful, page caching, and
more."
)
(
home-page
"https://www.gnu.org/software/artanis/"
)
(
license
(
list
gpl3+
lgpl3+
))))
;dual license
(
define-public
guile-reader
(
package
(
name
"guile-reader"
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment