Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
72ccbfe3
Commit
72ccbfe3
authored
9 years ago
by
Ben Woodcroft
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add ruby-hashery.
* gnu/packages/ruby.scm (ruby-hashery): New variable.
parent
0832804e
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ruby.scm
+35
-0
35 additions, 0 deletions
gnu/packages/ruby.scm
with
35 additions
and
0 deletions
gnu/packages/ruby.scm
+
35
−
0
View file @
72ccbfe3
...
...
@@ -3172,3 +3172,38 @@ (define-public ruby-rubytest-cli
Rubytest-based test frameworks. It provides the @code{rubytest} executable."
)
(
home-page
"http://rubyworks.github.io/rubytest-cli"
)
(
license
license:bsd-2
)))
(
define-public
ruby-hashery
(
package
(
name
"ruby-hashery"
)
(
version
"2.1.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
rubygems-uri
"hashery"
version
))
(
sha256
(
base32
"0xawbljsjarl9l7700bka672ixwznzwih4s9i38p1y9mp8hyx54g"
))))
(
build-system
ruby-build-system
)
(
arguments
`
(
#
:phases
(
modify-phases
%standard-phases
(
replace
'check
(
lambda
_
(
and
(
zero?
(
system*
"qed"
))
(
zero?
(
system*
"rubytest"
"-Ilib"
"-Itest"
"test/"
))))))))
(
native-inputs
`
((
"ruby-rubytest-cli"
,
ruby-rubytest-cli
)
(
"ruby-qed"
,
ruby-qed
)
(
"ruby-lemon"
,
ruby-lemon
)))
(
synopsis
"Hash-like classes with extra features"
)
(
description
"The Hashery is a tight collection of @code{Hash}-like classes.
Included are the auto-sorting @code{Dictionary} class, the efficient
@code{LRUHash}, the flexible @code{OpenHash} and the convenient
@code{KeyHash}. Nearly every class is a subclass of the @code{CRUDHash} which
defines a CRUD (Create, Read, Update and Delete) model on top of Ruby's
standard @code{Hash} making it possible to subclass and augment to fit any
specific use case."
)
(
home-page
"http://rubyworks.github.io/hashery"
)
(
license
license:bsd-2
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment