Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
74ba3a68
Unverified
Commit
74ba3a68
authored
6 years ago
by
Danny Milosavljevic
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add vsftpd.
* gnu/packages/ftp.scm (vsftpd): New variable.
parent
4786f515
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/ftp.scm
+40
-1
40 additions, 1 deletion
gnu/packages/ftp.scm
with
40 additions
and
1 deletion
gnu/packages/ftp.scm
+
40
−
1
View file @
74ba3a68
...
@@ -21,7 +21,7 @@
...
@@ -21,7 +21,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(
define-module
(
gnu
packages
ftp
)
(
define-module
(
gnu
packages
ftp
)
#
:use-module
((
guix
licenses
)
#
:select
(
gpl2+
gpl3+
clarified-artistic
))
#
:use-module
((
guix
licenses
)
#
:select
(
gpl2
gpl2
+
gpl3+
clarified-artistic
))
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
packages
)
...
@@ -243,3 +243,42 @@ (define-public filezilla
...
@@ -243,3 +243,42 @@ (define-public filezilla
directory comparison and more."
)
directory comparison and more."
)
(
license
gpl2+
)
(
license
gpl2+
)
(
properties
'
((
upstream-name
.
"FileZilla"
)))))
(
properties
'
((
upstream-name
.
"FileZilla"
)))))
(
define-public
vsftpd
(
package
(
name
"vsftpd"
)
(
version
"3.0.3"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"https://security.appspot.com/downloads/"
name
"-"
version
".tar.gz"
))
(
sha256
(
base32
"1xsyjn68k3fgm2incpb3lz2nikffl9by2safp994i272wvv2nkcx"
))))
(
build-system
gnu-build-system
)
(
arguments
`
(
#
:make-flags
'
(
"LDFLAGS=-lcrypt"
)
#
:tests?
#f
; No tests exist.
#
:phases
(
modify-phases
%standard-phases
(
add-after
'unpack
'patch-installation-directory
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
substitute*
"Makefile"
((
"/usr"
)
(
assoc-ref
outputs
"out"
)))
#t
))
(
add-before
'install
'mkdir
(
lambda*
(
#
:key
outputs
#
:allow-other-keys
)
(
let
((
out
(
assoc-ref
outputs
"out"
)))
(
mkdir-p
out
)
(
mkdir
(
string-append
out
"/sbin"
))
(
mkdir
(
string-append
out
"/man"
))
(
mkdir
(
string-append
out
"/man/man5"
))
(
mkdir
(
string-append
out
"/man/man8"
))
#t
)))
(
delete
'configure
))))
(
synopsis
"vsftpd FTP daemon"
)
(
description
"@command{vsftpd} is a daemon that listens on a TCP socket
for clients and gives them access to local files via File Transfer
Protocol."
)
(
home-page
"https://security.appspot.com/vsftpd.html"
)
(
license
gpl2
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment