Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
Guix
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
ogs
inf
Guix
Commits
77d7b57c
Unverified
Commit
77d7b57c
authored
7 years ago
by
Ricardo Wurmus
Browse files
Options
Downloads
Patches
Plain Diff
gnu: Add java-simple-xml.
* gnu/packages/xml.scm (java-simple-xml): New variable.
parent
ff3f6766
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
gnu/packages/xml.scm
+31
-0
31 additions, 0 deletions
gnu/packages/xml.scm
with
31 additions
and
0 deletions
gnu/packages/xml.scm
+
31
−
0
View file @
77d7b57c
...
...
@@ -44,6 +44,7 @@ (define-module (gnu packages xml)
#
:use-module
((
guix
licenses
)
#
:prefix
license:
)
#
:use-module
(
guix
packages
)
#
:use-module
(
guix
download
)
#
:use-module
(
guix
build-system
ant
)
#
:use-module
(
guix
build-system
cmake
)
#
:use-module
(
guix
build-system
gnu
)
#
:use-module
(
guix
build-system
perl
)
...
...
@@ -1175,3 +1176,33 @@ (define-public xerces-c
generating, manipulating, and validating XML documents using the DOM, SAX, and
SAX2 APIs."
)
(
license
license:asl2
.
0
)))
(
define-public
java-simple-xml
(
package
(
name
"java-simple-xml"
)
(
version
"2.7.1"
)
(
source
(
origin
(
method
url-fetch
)
(
uri
(
string-append
"mirror://sourceforge/simple/simple-xml-"
version
".zip"
))
(
sha256
(
base32
"0w19k1awslmihpwsxwjbg89hv0vjhk4k3i0vrfchy3mqknd988y5"
))))
(
build-system
ant-build-system
)
(
arguments
`
(
#
:build-target
"build"
#
:test-target
"test"
#
:phases
(
modify-phases
%standard-phases
(
replace
'install
(
install-jars
"jar"
)))))
(
native-inputs
`
((
"unzip"
,
unzip
)))
(
home-page
"http://simple.sourceforge.net/"
)
(
synopsis
"XML serialization framework for Java"
)
(
description
"Simple is a high performance XML serialization and
configuration framework for Java. Its goal is to provide an XML framework
that enables rapid development of XML configuration and communication systems.
This framework aids the development of XML systems with minimal effort and
reduced errors. It offers full object serialization and deserialization,
maintaining each reference encountered."
)
(
license
license:asl2
.
0
)))
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment